Home Forums Eye Tracking Devices et EyeX works once

Tagged: 

This topic contains 8 replies, has 4 voices, and was last updated by Profile photo of Grant [Tobii] Grant [Tobii] 1 day, 1 hour ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #6253
    Profile photo of Sidney Araujo Melo
    Sidney Araujo Melo
    Participant

    Hi, I’m not sure if this is the right place but I had this strange error twice. First time I installed the Tobii Eye Tracking Core, the EyeX worked fine. I tested some games and it worked perfectly. The following day, the EyeX wouldn’t even connect; two lights blinked and that’s it, no response at all (the tracking app was gray). I reinstalled it and it worked again. The following day, after restarting the computer, the device wouldn’t work again. So, right now I need to reinstall it every time I need to use it. Any help?

    Thanks in advance!

    #6265
    Profile photo of Grant [Tobii]
    Grant [Tobii]
    Moderator

    Hi @sidneymelo, The first thing I would suggest is to check for any running Antivirus or Firewall software on your system that may be running on your system and interfering with the connection. Also, could you kindly include the hardware specifications for your computer system? Do you have a secondary computer to test against our of curiosity?

    #7664
    Profile photo of Andrei
    Andrei
    Participant

    Sorry to hi-jack but I am having the same exact issue. After upgrading to V2.11 Tobii EyeX has stopped working after Windows Restart. “No eyetracker connected”. Nothing has changed except for installing the new Core installation.

    The only way for me to use it, is to uninstall and reinstall every time I want to use my Tobii Eye.

    Using Tobii.EyeX_2.1.1.293 also works. Something is obviously wrong with the new V2.11

    It would be great if I can at least find out the latest working version before V2.11 as my only option is V2.1.1 as this is working flawlessly.

    #7665
    Profile photo of Andrei
    Andrei
    Participant

    In addition the download section is extremely frustrating as I cannot find any of the previous versions. The only thing I can update is tobii eyex engine 1.9.5 and this has to be done via the v2.1 “check for updates” option.

    #7666
    Profile photo of Andrei
    Andrei
    Participant

    I have managed to find out a drivers repository and it has the following tobii versions:
    Tobii_Eye_Tracking_Core_v2.5.0.5588_x86 (WORKING)
    Tobii_Eye_Tracking_Core_v2.6.1.5748_x86 (SKIPPED)
    Tobii_Eye_Tracking_Core_v2.7.0.5807_x86 (SKIPPED)
    Tobii_Eye_Tracking_Core_v2.8.0.6094_x86 (SKIPPED)
    Tobii_Eye_Tracking_Core_v2.9.0.6265_x86 (SKIPPED)
    Tobii_Eye_Tracking_Core_v2.10.0.6432_x86 (WORKING)
    Tobii_Eye_Tracking_Core_v2.10.1.6463_x86
    Tobii_Eye_Tracking_Core_v2.10.20.6674_x86
    Tobii_Eye_Tracking_Core_v2.11.0.6827_x86 (NOT WORKING)

    I am going to go through the different versions and see which ones work as obviously v2.11 is messed up. It might work with the brand new Tobii but seems to have no love for the older EyeX models:(

    #7667
    Profile photo of Andrei
    Andrei
    Participant

    Tobii_Eye_Tracking_Core_v2.10.20.6674_x86 (WORKING)

    I would suggest only using version 2.10.20.6674 with Tobii EyeX as it is the latest version working. For whatever reason version 2.11.0.6827 is NOT WORKING with the older EyeX.

    In addition if you want to have your Tobii OFF make sure to set the Tobii EyeX Interaction to OFF then in Windows Services the Tobii Services to MANUAL and use the following CMD short-cuts when you want it enabled and disabled:
    START SERVICE
    C:\Windows\System32\cmd.exe /c ” net start “Tobii Service””
    STOP SERVICE
    C:\Windows\System32\cmd.exe /c “net stop “Tobii Service””

    #7675
    Profile photo of Grant [Tobii]
    Grant [Tobii]
    Moderator

    Hi @drei69, thank you very much for the detailed report and brining this to our attention.

    I shall forward your experiences to our development team who should hopefully be able to fix this problem for a forthcoming release, our apologies for any inconveniences during this time.

    #7676
    Profile photo of Anders Faust
    Anders Faust
    Participant

    Ok! got exactly the same issue!

    I opened a suport ticket and we first managed to find a solution (moving the display port cable on the second port, with full clean-up (registry/files/folders) and complete re-installation, but … then it failed again!

    I’ll try downloading 2.10 then and let you know too!

    (Official download link in case you need it)
    https://files.update.tech.tobii.com/Predator_Eye_Tracking_Core_v2.10.20.6674_x86.exe

    Will let you know if 2.10 works better


    Copy of my support ticket for information 😉

    Okay so here is the issue!

    I first installed successfully the Eye Tracker frm my Acer Z271T screen, and calibrated everything, installed Also some games using it (Assassin’s Creed Syndicate, Tomb Raider) Tracking was working awfully.

    Then I wanted to perfect the calibration of my Profile, so I started to calibrate it again, but here I closed the calibration before it was fully done, and from here I was completely unable to have the Eye Tracker working again!

    Well in fact, the Eye Tracker is connecting, starting, but I’m am completely unable to create a new calibration profile, the program simply doesn’t start at Alll!

    What I did:
    – Completely removed all drivers, software, then reboot, and reinstalled everything, eye tracker is detected, ok, but still unable to configure a new calibration profile

    – I then completely removed all drivers again, but this time I searched for every files related to Tobii to clear the to (Files AND Windows registry keys) I though this could also clean up “bad and/or corrupted” profiles configurations, to start a fresh one, then re-installed again, with no success!

    – I also tried the USB 2.0 trick, but still no luck (my USB controller is an ASMedia 3.1 Hub on motherboard) still no success!

    – Well I’m SURE my Eye Tracker is “working” because I can configure Windows Hello, see the camera filming my face, and Windows Hello do recognize me! but I can’t create/calibrate a trackinbg profile at all!

    – I also tried running tobii configuration from shell.

    When running this command:
    C:\Program Files (x86)\Tobii\Tobii EyeX Config\Tobii.EyeX.Configuration.exe -H
    the Eye Tracker program is starting, and Eye Tracker lights up, I see my eyes, then it’s simply closing, all other options (Configure, Guest, etc … doesn’t work at all)

    So here I am, I also joined the debug archive to this support request, hope you can help me.

    Thanks for your time!
    Looking forward for your reply!


    Answer
    Thank you for contacting us and sorry to hear about your issue. You could try to remove power cable of the monitor and then replug cable to reset it entirely.

    Eye Tracker needs correct information of screen to work properly, you could try to reinstall graphics card and screen driver as well. Replugging HDMI/DP cable sometimes does the trick. you could try it as well.

    It seems you have tried to delete tobii registries and folders. here are all of its location. maybe you can check if anything you missed.

    Registry
    HKLM\SOFTWARE\Wow6432Node\Tobii
    HKLM\SOFTWARE\Tobii
    HKCU\SOFTWARE\Tobii

    Folder
    %localappdata%\tobii
    %programdata%\tobii
    %programdata%\tetserver
    %programfiles%\tobii
    %programfiles(x86)%\tobii

    Please keep me updated, thanks.

    Best Regards,
    Tobii Tech


    Me again

    Okay well, It’s working again now!

    What I did exactly

    Removed all Registry Keys & File & Folders
    Uninstalled EyeChip usb, unplugged USB Cable
    Un-plugged Monitor Power while restarting windows

    Then I Re-installed Tobii software, and … it didn’t worked!

    So Last chance, As you said “Replugging HDMI/DP cable sometimes does the trick”
    I simply moved the DisplayPort cable on the second GPU DP Port, and Miracle, configuration started again!

    Absolutely tricky! but It’s clearly an issue during the Monitor identification or something like, Hope this also helps you troubleshoot more issues like this and Maybe find a patch for the next updates 🙂

    Thank you!

    #7683
    Profile photo of Grant [Tobii]
    Grant [Tobii]
    Moderator

    Hi @andersfaust, can you kindly confirm that downgrading to an earlier version of Tobii Eye Tracking Core SW resolved the issue? We are trying to link related problems through this solution. Many thanks.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.