Home Forums Game Integration infinite screen problem with the standalone elite dangerous: horizons

Tagged: 

This topic contains 13 replies, has 6 voices, and was last updated by Profile photo of Marcin Marcin 1 year, 11 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #4182
    Profile photo of Christopher Parsons
    Christopher Parsons
    Participant

    On the standalone version of elite dangerous horizons infinite screen does not kick in the vjoy. Only working with the steam version. I’ve tested with vjoy monitor.

    #4184
    Profile photo of Henrik [Tobii]
    Henrik [Tobii]
    Moderator

    Did you need to browse to the executable or was the install location resolved automatically?

    If you browsed to the executable then make sure that you browse to the actual game executable and not to the launcher executable. The game exe should be located at:
    “%LOCALAPPDATA%\Frontier_Developments\Products\elite-dangerous-64\EliteDangerous64.exe”

    There is currently no option to change the path to the game once you’ve browsed to it but you can reset the path to bring back the “Browse”-button by following these steps:
    1. Exit “Infinite Screen Extension” (right click on the systray icon and select “Quit”).
    2. Open windows explorer (Win+E).
    3. Navigate to “%LOCALAPPDATA%\Tobii\Tobii InfiniteScreen\Content\Settings”.
    4. Open the directory that corresponds to the game that you want to reset the path for (“EliteDangerousHorizons” in your case).
    5. Right click on the file called “HidMapperSettings” and select “Open with”. Select Notepad or any other text editor.
    6. Locate the XML-element called “<InstallLocation>” and remove it’s content (remove the text between <InstallLocation> and </InstallLocation>).
    7. Save and close the file.
    8. Launch Infinite Screen Extension and click the game tab of the game you just reset the path for. The “Browse”-button should now appear.

    #4191
    Profile photo of Christopher Parsons
    Christopher Parsons
    Participant

    Thanks.
    I opened the file and it was pointing to my \Steam\steamapps\common\Elite Dangerous Horizons. and not to my standalone. I was able to change it to the standalone client. It would be nice to have a button under each game to change the path for the exe or multi paths. some times I switch from Standalone or Steam depending if my friend want to watch my game play on steam.

    #4220
    Profile photo of Poisonberry
    Poisonberry
    Participant

    What should the exact value of the InstallLocation be? I cannot get vJoy to send anything to ED.

    My current value is
    <InstallLocation>Z:\SteamLibrary\steamapps\common\Elite Dangerous\Products\elite-dangerous-64\EliteDangerous64.exe</InstallLocation>

    but I launch this as a stand-alone in the same location as steam does not work well with horizons yet.

    #4224
    Profile photo of Henrik [Tobii]
    Henrik [Tobii]
    Moderator

    InstallLocation should not point to the executable directly but rather to the “root” game directory. In your case I guess that would be “Z:\SteamLibrary\steamapps\common\Elite Dangerous\”.

    but I launch this as a stand-alone in the same location as steam does not work well with horizons yet.

    Do you have a non-steam installation of Horizons? Could you please clarify what you mean?

    #4228
    Profile photo of Christopher Parsons
    Christopher Parsons
    Participant

    I made two file of HidMapperSettings, so I can switch them out if need to be. you should not install the standalone in the same folder as the steam’s version. Standalone has different folder structure.
    One for my Steam
    <InstallLocation>g:\Steam\steamapps\common\Elite Dangerous Horizons</InstallLocation>
    Other for my Standalone
    <InstallLocation>G:\Program Files (x86)\Frontier\EDLaunch\Products\elite-dangerous-64</InstallLocation>

    #4249
    Profile photo of martin powell
    martin powell
    Participant

    When I follow the steps to remove the install folder location, the browse button for Elite Dangerous Horizons doesn’t appear. When I quite Infinite Screen the location defaults to c:\users\username\appdata\local\frontier_developments

    There is no executable in this folder

    (Version 1.0.2.317 of Infinite Screen, Stand alone ED Horizons)

    #4251
    Profile photo of Henrik [Tobii]
    Henrik [Tobii]
    Moderator

    The path specified by InstallLocation in HidMapperSettings is not supposed to point directly to the folder of the executable but rather to the installation folder of the game (or the “root” folder if you like).

    ISE attempts to detect this installation folder at startup by reading information from the Windows registry which is created by applications when they’re installed. This folder is also verified to contain the appropriate executable (which is NOT located directly under this folder but rather in a sub folder).

    Where is your ED:H installation located?

    #4252
    Profile photo of martin powell
    martin powell
    Participant

    Hi, thats the correct folder then. The problem is that the VJOY doesn’t show any movement when ED is running and I also get URI invalid message in ISE (which I read is a known issue)

    Thanks

    #4253
    Profile photo of Henrik [Tobii]
    Henrik [Tobii]
    Moderator

    If you get the “Invalid URI”-message when launching a game then ISE won’t work for that game. Have you tried launching the executable directly instead of using the launcher?

    #4256
    Profile photo of martin powell
    martin powell
    Participant

    I get an “Invalid Login – please use the launcher”, I have got FSX working (via Steam) but not the stand-alone ED 🙁

    #4257
    Profile photo of martin powell
    martin powell
    Participant

    I have got ED working by using the Steam edition. The standalone version doesn’t work.

    #4262
    Profile photo of Benjamin Corbus
    Benjamin Corbus
    Participant

    i also had the invalid URL massage.
    i fixed it by disabling Compatibility mode for Elite Dangerous wich i used for fixing an error of a earlier version of elite
    you could also try not running elite with admin rights.
    after that i could bind the axes ingame.

    #4288
    Profile photo of Marcin
    Marcin
    Participant

    Here is what I have done in order to make Tobii working with ELite Dangerous Horizons: Go to %HOMEPATH%/AppData/Local/Frontier Developments/Elite Dangerous/Options/Bindings for example: C:/Users/cmdr_speedy/AppData/Local/Frontier Developments/Elite Dangerous/Options/Bindings rename Custom.1.8 to Custom.0.8. Restart of the game and Tobii apps. That’s it!

    It’s awesome that you want to help the community, we really appreciate it. What you’ve suggested here will however not fix the “Invalid URI”-problem and to avoid confusion I’ve decided to “delete” it.
    /Henrik

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.