Home Forums Unity SDK Failed Controller Bindings Reply To: Failed Controller Bindings


Hi Grant, thanks for the reply.
Honestly, I’ve started new projects and deleted and reimported everything about 5 times now, so I am thinking this is not the problem.

I’ve also tried both Unity 2019.4.12f1, and the newest version 2020.2.7f1

I’ll outline my steps (using Unity 2019) and see if you can see somewhere where things go wrong:
1. I have SteamVR in the background; and confirm that the Vive, controllers, base station are all working correctly.
2. I then follow the steps 1-4 laid out here: https://vr.tobii.com/sdk/develop/unity/getting-started/vive-pro-eye/ … importing packages into my default ‘VR’ project. Packages are: TobiiXRSDK_2.0.0.174 and Vive-SRanipal-Unity-Plugin
3. After, I load Example_HandEyeCoordination. I check in the XR Manager that Vive is supported and at the top of the list, and I check the box for supporting SRanipal.
4. I can play the scene in Unity, but it does not even come into the view of my Vive.
–> at this point, if I hit run I get a persistent error for duration of runtime that is:
"DIINotFoundException: openvr_api Valve.VR.OpenVr.GetInitToken () (at Assessts/TobiiXR/Examples/Utilities/Controller/Plugins/openvr_api.cs...)"
5. I close and restart Unity, problem persists.
6. At this point, I go back to step 3 with a new project and figure I need to import the SteamVR asset package from asset store.
7. It asks if I want legacy mode or Unity XR mode. I’ve tried both lines, and the legacy mode goes into a looping which simply never works. So I choose XR mode.
8. Says it is successful, and may need to restart editor. So I do that.
9. Upon restart, if I play the scene, I get an error seen only in my HMD “the action manifest for [Testing] “myProject” was not found. File path C:…/”myProject”/Assets/StreamingAssets/SteamVR/actions.json”
10. Now, to fix this I go to “Window”, “Steam VR input”, and it says “It looks like your project is missing an actions.json, would you like to use the example files?”… OK. Compiled. Saved. I also open the bindings UI and see that they look fine.
11. Back to scene. We run it now, and the camera is in a weird spot, halfway into the floor. I move the “Tobii XR Player Hand-Eye” transform from “0, 0, 0” to “0, 0.33, -0.33”. Now the camera is fine.
12. I can see the ‘gaze outline’ in light blue around the blue ball, but the trigger pull does nothing. I also notice my controller is not where it should be, but rather somewhere above me to the left. However, it does move how I move it, so the transform information is getting through.

Similarly, if I drag the Dev Tools prefab onto the main camera… my gaze does indicate I am looking at the settings gear, but the trigger does not open it.

Any ideas?