Home Forums Unity SDK Gaze indicator random lag Reply To: Gaze indicator random lag


I tried to upgrade the project, but it’s a mess now.

In my original project I have two folders, TobiiXR and TobiiPro and the package is not listed in the Package Manager (makes sense, this is from before the Package Manager).

When I delete both TobiiXR and TobiiPro in Windows Explorer, not in Unity, open Unity and then import the 3.0 SDK package, I get several compile erors. So I restarted Unity, but the errors remain, for example:
C:\VR\Tobii SDK\Runtime\Core\Helpers\XRDisplaySubSystemHelper.cs(11,46): error CS0246: The type or namespace name ‘XRDisplaySubsystem’ could not be found (are you missing a using directive or an assembly reference?)
Library\PackageCache\[email protected]\Editor\XRGeneralBuildProcessor.cs(162,33): error CS0234: The type or namespace name ‘BootOptions’ does not exist in the namespace ‘UnityEditor.XR’ (are you missing an assembly reference?)

This is in Unity2019.2.17f1

Since you recommend 2019.4.5 for SDK 3.0 I started again, upgrade the project to 2019.4.13, as that is the Unity version I have.
Also no Tobii XR SDk in the package list. Did the same steps, removed TobiiXR and TobiiPro and iported the SDK 3.0 package and again compile errors:
Error: Could not load signature of Tobii.Research.Unity.CalibrationThread:get_EyeTrackerIF due to: Could not load file or assembly ‘Tobii.Research.Mono, Version=, Culture=neutral, PublicKeyToken=70326046dcdce6cb’ or one of its dependencies. assembly:Tobii.Research.Mono, Version=, Culture=neutral, PublicKeyToken=70326046dcdce6cb type:<unknown type> member:(null) signature:<none>

Restarted Unity, still compile errors:
Assets\Scripts\GazeVisualizer.cs(3,13): error CS0234: The type or namespace name ‘Research’ does not exist in the namespace ‘Tobii’ (are you missing an assembly reference?)

Copied the folder TobiiPro back from my backup and restarted UNity and then I got the meesage that I needed to switch to the XR plugin system.

Now the compile errors ar gone, but the gaze visualizer does not move at all anymore. I don’t see errors, so I have no clue what is happening. I see a debug statment:
Tobii eyetracking input value: True
But I don’t see the G2OM message that I saw before.

So I’m completely lost about what’s happening and if this has solved my problem.
Hope you can help me out.