Home Forums Eye Tracking Devices Eye Detection Indicator stuck in Initializing Reply To: Eye Detection Indicator stuck in Initializing


I had this issue as well. It had been working for several days until I unplugged the device to re-route the USB cable and plugged it back in. Computer restarts and enabling/disabling the USB device did not work. After a restart it would be stuck on “Initializing”. If I disconnected and reconnected the device I would get the message “Eye Tracker Connected” over and over again from the Tobii EyeX Engine tray application and it would not longer load.

Originally I got everything setup using https://steelseries.com/sentry/start, which is the link that comes with the instructions for the device. It may look like the better link to use is http://developer.tobii.com/eyex-setup/

I tried disconnecting the device, closing the Tobii EyeX Engine, and uninstalling everything in Programs and Features that started with “Steelseries” or “Tobii”. Then I re-installed using the http://developer.tobii.com/eyex-setup/ link which appears to install much more updated software which also updates the firmware on the Eye Tracker. All good again so far!

It may be that just a simple re-install of everything would’ve worked, but new link has newer software.