Home Forums Eye Tracking Devices Acer Predator Z271T EyeTracker "not working" (somehow fixed)

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #12039
    Ghostychan
    Participant

    Hello Guys!

    Mostly I’m writing this for the Tobii Staff, and also for other frustrated users.

    Sadly the older thread is already closed, so I’m recreating it with some more information.
    Simply said, my Problem was the usual Z271T EyeTracking not connected issue, due to my apprenticeship as an IT-Technician, I learned many tricks and was never the guy, who took the chance to send that monitor back to Acer. Now after giving up for 1year, I restarted the troubleshooting. Having this Monitor for more than 2years, already. the Eyetracker was working at the beginning.. then all of a sudden it stopped.. and was kinda working from time to time, already searched for solutions posted in this forum, other forums, etc. but never had anything working.

    Soo.. long story kinda short:
    Already tried the default steps (from changing the cables to reinstalling windows etc., so no hard- or software issues). Multiple reinstalls of different versions from EyeTracking Software (the default, the predator, Acer, etc.) nothing really worked overtime.

    Kinda gave up on the point where I saw that the devices are all shown up in the device-manager, logs haven’t given me any clue and due to the posts, I wasn’t even trying my luck with any support.
    (Also having issues with the monitor gsync module itself too, so kinda thought it was somehow in a combination that the eye tracker wasn’t working)

    Anyway. This Morning I decided to pick it up again and man.. this was painful. xD
    Started out with the usual “Eyetracker isn’t available” – Tobii Service running, Devices (USB-Devices>EyeChip,(Inputdevices?)>Tobii Device, Tobii Eye Tracker HID are shown in the device-manager (all showing up with status ok).

    So when I restarted the service, the eye tracker was working for some seconds. Then it went back to not available, restarted the service again -> working again for some seconds. Dug through some folders shipped with the Eyetracker Software Installation and found the EyeTracker Core Light.. there I just noticed that the eye tracker is hanging up at the calibration part, then disconnected and connected to the “faked” Core Light “Tracker device”. (I hope you guys at Tobii still can follow me here… sorry, can explain that a bit more detailed if needed)

    So I went back eye tracking options and reset them to default
    Noticed (as already ages ago before), when the Eyetracker isn’t working you can’t see any details about the Model, SN, Firmware. After a settings reset it somehow flipped back on, after some seconds dead again.

    Then I started to dig a bit more towards the drivers.. (more precisely towards the Eye Tracker HID)
    First step: deleted all device drivers from Tobii
    (EyeChip, Tobii Device, Tobii Eye Tracker HID)
    Second step: action > search for changed devices
    Third step: Eyechip showed up, the rest didn’t (AFAIR)
    Fourth step: reinstalling the drivers, from the C:\Program Files (x86)\Tobii\ HID & IS3 Driver
    Fifth step: restarted the service (Tobii Service)

    and at the moment i’m happily using it, even tho I needed to recheck the on-off (in the tray settings).

    Now its even showing some values in the About us:
    Eye Tracking Core SW 2.13.4.7864
    Eyetracker-Model IS4 Large 101
    SN (starting with) KS05xxxx
    Firmware 2.27.0-4014648
    Controller Core not available
    Controller Driver 2.0.4
    Service 1.25.1.7338
    Engine 1.24.1.7398
    Config 4.10.1.1130
    Interaction 2.13.1.5344
    Face Auth 1.0.21.207
    Eye Tracker HID 1.9.862.0
    Device 1.9.862.0
    Overview 1.0.2.49
    Intro 1.0.1.46

    well I don’t know if it helps someone out there, I hope it will.
    I already tried so many different approaches that this procedure fixed it for me now. Let’s see how long, atm its about active for more than 1 hour (gaze while writing this text to see when it changes).

    Also im sorry if there are any questions left open, gonna try to provide support too if needed. Im Austrian so mainly speaking & writing german, I hope it wasn’t too bad to read this wall.

    (I made some troubleshoot packages when it wasn’t working, even tho i think this won’t give much help too as I have tried to understand most of the things collected together in there. And just found out that the calibration part is somehow throws off the eyechip / eye tracker hid

    Let me know (if) how and where I should provide the packages (even tho I haven’t looked for the zipped packges, i’m just checking the all the folders for some logs in appdata/local/tobii/, etc.)

    Sincerly,
    Ghostychan (Lukas)

    #12040
    Ghostychan
    Participant

    Just to keep you guys updated,
    Day 1: played Assassins Creed Syndicate with the Eyetracker, totally working fine. No problems!
    Day 2 (just started): Eyetracker atm still working…

    Seems like something got messed up with the drivers & (or) the calibration part.
    Let’s see if it may act like usual after a week or so that it randomly stops again.. but for now, I’m happy :3

    Wishing all of you a good day.

    #12043
    Grant [Tobii]
    Keymaster

    Hi @ghostychan, thank you very much for this detailed information which I hope will be of use to other users who are facing difficulties with the Z271T.

    Our sincere apologies for this inconvenience caused, we realise a small number of users have faced this problem and that returning the monitor to original manufacturer is of course not the ideal solution.

    We hope that the advice you have so kindly shared will be of use to users in a similar situation as yourself. Best Wishes.

    #12048
    Ghostychan
    Participant

    Hello @Grant, good to hear that.

    Sure firstly I was pissed, like most peoples.
    Mostly because I got that monitor with the eye-tracker as a present.

    Still working, with replugged cables (so changed a bit of the cable mess) and it’s still working… I have still had no clue, how or why the drivers did act up so weird.

    Thanks for the response.
    Best wishes to you and the other guys at Tobii too. Keep up one of the greatest technologies (as a gamer, am such a fan)

    Ps:
    Used it today with Tobii Ghost (for Streaming Overlay) and it was working fine too.
    So thanks to you too Grant, due to the previously tried methods from the other threads, I learned at least some of the debug steps.. that I could exclude from their faultiness πŸ˜›

    (I hope it’s fine to post also the stream video link, just as proof for others):
    https://www.twitch.tv/videos/489852182
    (Twitch Stream from Escape from Tarkov, using the Z271T with Eyetracker.. sadly the tracker bar itself a bit too low when I’m sticking too close to the monitor xD)
    Also just noticed, maybe my fault but due to some custom game resolution (running the game in like 2k, while the desktop is at 1080p)
    Maybe the Ghost Overlay is still at 1080p? (or it was just my Streamlabs obs wrongly resized it down for 720p stream).. Just putting this here too (sorry πŸ˜€ )

    Sincerely,
    Ghostychan

    #12428
    Kristian Vlajic
    Participant

    Hey @ghostychan/

    thank you for your post!
    I most likely have the same issue as you and gave up like a year ago after finding out that something is off with the drivers, but i couldn’t find a solution to it.
    I’m really hoping to fix my issue with your description, but i can’t find some things you described.
    What is the “EyeTracker Core Light”? I can’t find a folder named like that in C:\Program Files (x86)\Tobii so i guess it’s some other application that i may not have installed yet? Or i just didn’t understand what you where describing in that paragraph (I’m not a native speaker).
    And how did you reinstall the drivers in C:\Program Files (x86)\Tobii\HID and C:\Program Files (x86)\Tobii\IS3 Driver, i couldn’t find any .exe in here except dpinst.exe, but this didn’t do anything.
    I would be so thankful if you could help me with this!

    Sincerely,
    Kristian Vlajic

    #12449
    Kane Hobday-Weiler
    Participant

    I have done every step and this does not work

    #13855
    Donald Johnson
    Participant

    Hi ghostychan,

    I’ve followed your steps and finally, my tracker seems to be working. I’ve been suffering as many others have with this issue for that last couple of years. Thank you so much for your hard work and for posting this solution. I thought for sure this was a hardware issue for me. Maybe it still is, time will tell. I’m gonna try Project cars for a bit and see how long this works.

    Cheers!

    #14102
    Alan
    Participant

    Hi Ghostychan, i am another frustrated user who cant get this thing to work, its the second monitor, as i sent the first one back after about a month trying to get it to work, even reloading windows like you, all to no avail. When i got the second one i thought that i could not be unlucky enough to get another bad one, how wrong i was. I have come to the conclusion that the monitor/eyetracker is totally unfit for purpose.

    #14103
    Ghostychan
    Participant

    Hello and sorry everyone for beeing quiet. As I’m having much stuff todo, eitherway.

    First of all I can never assure that any of this steps will fix it for everyone, I’m just lucky that the hardware is “still working”.
    I ended up starting and stopping the Tobii Service whenever I like to. This also means I cannot assure how long its working in a period etc.

    Now comming back to the forum and reading all of your struggles. I’m giving this another try while writing it down here, how & why I continue there.

    1. Starting Tobii Service
    Seeing in the tobii tray icon loading up, Eyetracker is shining red. After the “init”-process (the loading is over) my Eyetracker shuts down, “not available”.

    2. Opening up Tobii – to verify the status in the about us section
    There clearly from “Eyetracker-Model” to “Tobii Controller Core”: “Not available”. Everything else IS showing up a “correct looking” number atleast.
    (Here are mine from top to bottom (short):
    Windows Pro Insider Preview Version 10.0.19592 Build 19592 -> switched over the it, but shouldn’t help. Just using the new things in WSL πŸ˜‰

    ETC SW (Eye Tracking Core) – 2.13.4.7864
    CD (Controller Drive) – 20.4
    S 1.25.1.7338
    E 1.24.1.7398
    C 4.10.1.1130
    I 2.13.1.5344
    Face Auth 1.0.21.207
    Eye Tracker HID 1.9.862.0
    Device 1.9.862.0
    Overview 1.0.2.49
    Intro 1.0.1.46

    I just hope I dont have a typo in there xD )

    3. Device Manager
    straight down to usb-devices (atleast on my side): EyeChip – disable & enable (re-enable) it.
    Eyetracker comes back, (wanted to turn on Gaze Trace) it turns off some seconds after again. So the same problem where I started at ****.
    Switching the view to show devices from containers. Which shows me EyeChip (and its Item below <- the one we disable later delete etc.)
    Aswell as the Tobii Eye Tracker HID with Tobbi Device & Tobii Eye Tracker HID inside (you will see its connected to the EyeChip, when disabling it)

    4. Following my previous strat
    turned out, windows 10 is faster than me doing the manual driver installation. And the reinstalled drivers aren’t working here. Even after restarting the service.

    wasted a bit of time trying to install / reinstall / remove & search for changed devices inside the device manager just helped till the eyetracker actually would start to eyetrack.. like atleast feeling like, at that moment where it inits the eye tracking it crashes the “device”.

    well. either I’m missing a point from myself before that I cant figure out yet – as power management settings of the tobii devices are not checked.

    I’ll give this another try soon again
    For others I can just recommend trying out between re-plugging the cables (may some faulty port? -> could be on the display too.. so yeah..)
    check how the “about us”-section is behaving while toggling EyeChip off and back on (may you get some Model & Firmware Data out for a short period)
    There are plenty local files, I wouldn’t recommend to just remove them, more to test out the Programs provided inside (I’m finding a “Test Core” which fakes the eyes and showing up in the “about us”-section..

    If nothing shows up in the device manager, check your cables & drivers (may you can find drivers in the tobii folder as me does)
    The Tobii Service is a good point to go, restart it – may you see your eyetracker comming back to life for some seconds.
    May reinstalling the Tobii Software (would try different ones – but please only provided from tobi & vendors / known sites)
    while deinstalling make sure EVERYTHING is getting deleted.

    Anyway. I hope I get some more ideas & a bit of time to debug this out more πŸ™‚
    Would be interesting if there are more possibilities provided (except the Troubleshoot Package, which I can’t send up due another error.. :D)

    #14104
    Alan
    Participant
    #14105
    Alan
    Participant

    Unfortunatly, dont know how to get into my monitor to check this “fix”. i never got a reply from “Dick1970”

    #18276
    Ghostychan
    Participant

    Thanks to you Alan, I managed to resolve this, “atleast how I’ve been seeing it commonly done”.

    It should be clear but: UNPLUG EVERYTHING! (NO POWER; NO VIDEO CABLE; NOT stuck to the foot neither to a monitor bracket. I ended up putting it down on a chair, while holding it the whole time between legs.. so no proper setup or space.. If inside make sure you’re not charged. Ground yourself. Any damage on the monitor & opening it is probly not a good idea due to warranty, so If you dont care and it can get broken – feel free to take a journey inside it. With slow pace and enough patience you can get this done pretty easily once you get the thrill.

    With more knowledge.. I started teering it slowly apart.. till the point where I just was like “Ah f*** it, just get it done.. took my whole sunday” so prepare for a bit saltyness when doing this as a typical user. I’ve never done such things like opening up a monitor.. but have a basic understanding of electricity etc.

    So the main issue seems to happen to the grounding not beeing connected anymore. I’ll post a image story I took all the way.. even to check whats exactly inside the Tobii stripe.
    Everything looked fine at the beginning, taking a closer look (after slowly loosen the cables one by one – while softly pulling down each electricity
    conductive tape).
    I saw that there was an heat shrink tubing on one side which had the black (grounding) cable left with no connection to the metal foil (which is getting grounded like shown on the picture). So that this whole electricity flow works (aka the tobii works) –
    all I did was cut very softly around the cable to pull off the rubber to get a bit more of this black cable out of there.. trimmed the isolation off and bend those directly back into the metal shield and spinned it together with the metal “things”? (sorry im not a electic guy, even tho im very interested xD).
    So for me its like: just grounding it because the part which is shown in the post, makes now total sense – the grounding it needs is not hitting anything due this cable isn’t connected with the metal shielding anymore.
    with some electric tape I wrapped the whole again (just grounded it back to the foil, thats all). that was the easiest part tho of this whole process.

    Now to the taking apart the monitor backplate.. first of all, like I have done it – this DOES LEAVE visible marks! All I needed was a small – screwdriver bit (to hold space open when re-adjusting) my “fry tool” – looking from a leatherman.. jumping through it went better the more I understood that this breaking sound mostly is Ok.. (broke some plastic clips holding it together off, but there are multiple so.. can live with that). Start of with the hole on the bottom right.. and work yourself around, with each crack you hear you can continue, you will see it will get more off and off the further you get (I just stuck it in between and turned/shaked it a bit till I heard a crack.. took the bit a bit further and stuck that fry tool the further it still fit in). Just watch some youtube videos for a bit better understanding there. It takes some dedicating to do this.. xD

    After all of those clips went of the backplate jumps up a bit, watch out due 2 wires are connected (depending where the usb-hub & control panel (joystick & buttons) are, there I just started with looking if I either slowly stuck off the duct tapes or/and the wire connectors – with some tweezers you can just push the top of those pins, and pull it off slowly with you hand (unpluged only the left side (where the buttons & joystick are) and just flipped the plate open, after the cables where free. worked down to the eye bar and followed the cables it was too awesome. Inside the bar the pins are clearly showing there are atleast 4 cable cores – black | grounding, red | power / v , green | ? and white | ?(.. and another black one..) but on the side of the usb hub there are only 3 cores (red, white & green..) so where the f*** is the ground gone to. -> search for some shrinking tube, there the black one should’ve been connected to the isolation “firm(?)”.

    Hope this clears it up a bit more now. As it took me now another day to do this process, I had also problems to many many many manual deinstallations that my tobii wasn’t getting installed anymore (like the installer always updated, instead of installing normally.. due I had no Tobii Service file.. or any other tobii application anymore on my drive – yes, manual deletion.); ended up with only getting the firmware files installed… after long trying and trying and… trying..
    I went multiple times through my windows registry (regedit); searching for “Tobii” and deleted everything except the drivers (mostly something with driverstore; or with no permissions, due it was some kinda of filesystem thing). Many tries of this later. Multiple times those registry finds.. and hours later….

    It started to work. The installation was finally done correctly, instead of just updating.. Software is starting up.. and… calibration process is working!!
    I’m amazed. Like Dick1970 said “a creative solution” to use that shielding to connected one cable core to the grounding.. leading it to the bare metal in there to get the ground it needs.. (normally you would hook it up to some grounding (at the power supply)..

    So.. this was my problem atleast. As we see if from Dick1970 this seems to be common.. and I’ve seen those typ of groundings already.. (asked some with more knowledge for that.. but wanted it to work for now..)

    I took some pictures all the way, showing a bit closer view of what to watch out for and what I did (not completly but explained I hope so far good enough):

    Β Acer Predator Z271T EyeTracker “not working” (somehow fixed) | Disassembly & Tobii Eyebar fix

    Thanks again Alan for the hint..
    Thanks to Elite Dangerous, I went into those struggles.. xD
    And now.. its already 3AM on Monday.. hope this helps! πŸ™‚

    Sincerely,
    Ghostychan. Lukas N

    #18281
    Ghostychan
    Participant

    Now still enjoying it in elite dangerous (day1-2)

    #18305
    Alan
    Participant

    Hi Ghostychan, im glad to have been of some help. your post inspired me to open up my monitor, i followed your breakdown instructions earlier this afternoon. The actual fix only took a couple of minutes, most of the time was spent trying to open the monitor and the end result is, it is now working perfectly, so i recomend to anyone who has the same problem, to do the same. It seems to me that neither Asus nor Tobii want to take responsibility for bad workmanship. Thanks man.

    #18559
    Ghostychan
    Participant

    Hello!

    Glad to hear that this worked for you too!
    Atleast we got this finally!
    On my side tho I still will need to figure out another problem with the monitor itself.. which is way worse than this cabling issue.
    Basicly said: in Rocket League on more blue-ish maps (I think) the GSYNC Module fucks up something with the coloring and brightens up dark zones / shadows with even more blue coloring making the full screen kinda distracting with all the blue-ish fucked up colorings (it’s a bit hard to explain, sorry).

    I’ve read that this should be resolved by updating the gsync module, but needs a shipping to asus.. which well I don’t wanna do since the delivery was already such a mess.
    I found the workaround to unplug the power (to monitor) and this way it resets back to normal.. I try to avoid those games but even got used to this so when I play for example rocket league its kinda annoying but you can still live with it.. so I’ll probly take some time and try to get this update myself somehow possible πŸ™

    Next monitor gets a seperate Tobii Device.. or I’ll try to convert this one out xD

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.