Home Forums Software Development After updating to the new Tobii.EyeX_0.10 calibration fails

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #1720
    Gal Sont

    I calibrated It just before the update on 0.8 and it worked perfectly, now I’m stuck…
    I do see my eyes in the first step
    Restart didn’t help.
    Stack trace :

    Application start date: 9/23/2014
    Application start time: 17:56:41
    Product version: 0.10.0
    Package type: OEM

    17:56:41 INFO Start Tobii Configuration Application.
    17:56:41 INFO Context_1.TransportLayerConnecting…
    17:56:41 INFO Context_1.TransportLayerConnected!
    17:56:41 INFO ServerStateStore: Load server states
    17:56:41 INFO TetConfig: DisplayDevices::GetDisplayDeviceName(173) Message=No displayDeviceName found for index 3
    17:56:41 INFO TetConfig: DisplayDevices::GetMonitorDeviceName(206) Message=No Monitor Device Name found for display name \\.\DISPLAY1 and index 1
    17:56:41 INFO TetConfig: DisplayDevices::GetDisplayDeviceName(173) Message=No displayDeviceName found for index 3
    17:56:41 INFO ResolveConfigurationFlow: Run
    17:56:41 INFO CalibrationFlow: Run
    17:56:41 INFO Flow navigator: step – Tobii.EyeTracking.Common.Calibration.ViewModels.EyesPositioningViewModel, index – 0 activated
    17:56:41 INFO EyesPositioningViewModel: Activate
    17:56:41 INFO EyesPositioningViewModel: Activated
    17:56:41 INFO EyesPositioningViewModel: Start
    17:56:41 INFO EyesPositioningViewModel: Stop
    17:56:41 INFO EyesPositioningViewModel: Stopped
    17:56:41 INFO EyesPositioningViewModel: Started
    17:57:15 INFO EyesPositioningViewModel: Stop
    17:57:16 INFO EyesPositioningViewModel: Stopped
    17:57:16 INFO EyesPositioningViewModel: Deactivate
    17:57:16 INFO EyesPositioningViewModel: Deactivated
    17:57:16 INFO Flow navigator: step – Tobii.EyeTracking.Common.Calibration.ViewModels.CalibrationProcessViewModel, index – 1 activated
    17:57:16 INFO CalibrationProcessViewModel: start calibration
    17:57:16 INFO CalibrationProcess: StartCalibrationProcessLoop calibration
    17:57:16 INFO CalibrationProcessViewModel: show stimuli – 0.5,0.5
    17:57:21 INFO CalibrationProcessViewModel: show stimuli – 0.9,0.5
    17:57:23 INFO CalibrationProcessViewModel: show stimuli – 0.9,0.1
    17:57:26 INFO CalibrationProcessViewModel: show stimuli – 0.5,0.1
    17:57:28 INFO CalibrationProcessViewModel: show stimuli – 0.1,0.1
    17:57:31 INFO CalibrationProcessViewModel: show stimuli – 0.1,0.5
    17:57:33 INFO CalibrationProcessViewModel: show stimuli – 0.1,0.9
    17:57:35 INFO CalibrationProcessViewModel: show stimuli – 0.5,0.9
    17:57:38 INFO CalibrationProcessViewModel: show stimuli – 0.9,0.9
    17:57:40 INFO CalibrationProcess: Computing calibration
    17:57:40 INFO CalibrationProcessViewModel: start computing result
    17:57:44 INFO CalibrationProcess: Failed calibration with exceptionTobii.Gaze.Core.EyeTrackerException: Firmware error: Operation failed. (error code FirmwareOperationFailed).
    at Tobii.EyeTracking.Common.EyeTrackerConnection.EyeTrackerEtcc.ComputeCalibration()
    at Tobii.EyeTracking.Common.Calibration.CalibrationProcess.ComputeCalibration()
    at Tobii.EyeTracking.Common.Calibration.CalibrationProcess.CalibrationProcessLoop(Uri eyeTrackerUrl, Point2D[] calibrationPoints, CancellationToken cancellationToken, Boolean recalibrate)
    17:57:44 INFO CalibrationProcessViewModel: calibration process completed, result – AllPointsFailed
    17:57:44 INFO CalibrationProcessViewModel: stop calibration process.
    17:57:44 INFO CalibrationProcess: Stop
    17:57:44 INFO Flow navigator: step – Tobii.EyeTracking.ControlPanel.Calibration.ViewModels.CalibrationProcessFailedResultViewModel, index – 3 activated
    17:57:50 INFO CalibrationProcessFailedResultViewModel: Cancel
    17:57:50 INFO CalibrationViewModel: StopCalibration
    17:57:50 INFO EyesPositioningViewModel: Stop
    17:57:50 INFO EyesPositioningViewModel: Stopped
    17:57:50 INFO CalibrationProcessViewModel: stop
    17:57:50 INFO CalibrationProcessViewModel: stop calibration process skipped as no calibration process is active.
    17:57:50 ERROR CalibrationFlow: Calibration was aborted
    17:57:50 INFO ResolveConfigurationFlow: Done

    Gal Sont

    Update – reconnected my Rex and it worked right away with my last calibration. Took a chance and recalibrated… guess what happened – It worked!
    So I’m guessing something in the eyex firmware is bugged.
    The software Itself seems to work.

    Mattias [Tobii]

    Hi Gal Sont,

    We are looking into this. Could you please help us check something? Check that your screenplane seems to be set up all right. You can do this from the settings panel. Firstly check that it identifies the screen correctly, and secondly that the two indented (barely visible) marks on the EyeX controller coinsides with the “scale-marks” drawn on the screen (i.e they should not be coincide with the full length of the Eye-tracker as with the REX). Errors with the screen plane can give errors of the kind you experience but it should not happen due to an upgrade, but it is nevertheless worthwhile to check while we are looking into other sources of error.

    Please post here if this solves something for you.


    Gal Sont

    Hi Mattias, thank you for your prompt reply.
    I use a 24″ screen, when i mount the camera on the screen itself the software wants me to bring the screen so close to me that it is impossible to work.
    This is why I built a special “shelf” that i use for the past 2 years with my REX and recently with the eyeX. It was fine until the update.
    Here you can see the “shelf” i built – http://youtu.be/WWMsPpBRV3A?t=58s

    Thank you,

    Mattias [Tobii]

    Hi Gal Sont,

    Quick Update. We are looking into this bug, but it may take a little while before we have a solution for you to try out. If you feel that you are completely blocked in your development due to this, then please contact our support team and check if they can help you with a temporary downgrade, or some other short term solution.


    Gal Sont

    Thank you.
    I use my REX for development now but I’m afraid my users will upgrade and have the same problem…

    Mattias [Tobii]

    Nice to hear that you are not stuck. On the topic of other users I truly believe that the calibration problem you face only affects a minority of our users. That is actually a problem, beacuse we are having some difficulty reproducing it in our Quality Assurance lab. So for most of your users this should not be a problem, but we will nevertheless work hard to sort it out for those who see it.


    Gal Sont

    Thank you.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.