Home Forums Software Development Bug: "Already installed"

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #8852


    Im on Win10Pro for Workstations. With the recent RS5 update something messed up and I had to reinstall all my USB devices. All works fine again – except for Tobii. I needed to uninstall Tobii and since than when I try to reinstall it I get the message “Tobii Eye Tracking Software is already installed” and the installation won’t continue.

    I already followed the instruction to start a fresh clean install:
    Additionally I used “Windows Install Clean Up” to make sure the computer is erased from all Tobii stuff. Still I get the error.

    Is there any way to force the installation, to ignore error messages or whatever ?
    Or does anyone has a clue what needed to remove, too, which is missing in the help desk of Tobii ?

    I tried Tobii on my Laptop (Win10 Pro RS5) and it works there without flaw. But I need it to work on my Workstation.


    Grant [Tobii]

    Hi @suppenkoch, sorry to hear about your issues.

    It’s certainly rather strange that there remains artefacts after installing following the advice as given out in the above link and stranger still that the issue is not reproduced on your other system.

    RS5 has not yet been comprehensively tested, so I will check with developers but in the meantime have you tried using an Uninstaller Software (eg. IOBit Uninstaller) that could monitor and hopefully uninstall all traces? Please try it out and let me know how you get on.

    Thanks for your patience whilst we try to find a resolution to this issue.


    Yes, I am also suprised. Especially as on two different machines with same Win10 version I only have issues on one of them.
    However as mentioned above I tried already the Windows Install Clean Up tool. But due to your suggestion I also tried IObit uninstaller now and it can’t find any traces on Tobii, Tetserver or any other search word regarding this software.

    Grant [Tobii]

    hi @suppenkoch, that’s a shame. So to confirm, that even after using IOBit, the problem persists with installation?

    I have sent you by PM a PDF which explains in greater details some steps you can take to fully remove all traces of Tobii Core Software.
    Please try it out and let me know on this thread how you get on. Many thanks.


    Hi Grant,

    yes even after using IOBit the problem persists.

    I followed your guide in your PM. Found some traces and successfully removed them. However, the problem persists. I restarted twice and made sure everything disappeared (no traces are found at all now), but still only I double click Tobii Eye Tracking Core Software installation file I get the message Tobii is already installed and installation aborts. Why ?
    I dont understand.


    I made another try.
    After cleaning the system I could force a reinstall by adding to the command line “-h” as string. I needed to reaccept the EULA and installation started through without any further questions. When he told he succeeded, he seemes not do to so. On the desktop or startmenu no quick link is generated. Further if I go down to the path of installation and try to manually start Tobii, he reports a problem as “something went wrong, contact your supplier”. If I try to clean again computer from all traces I am stucked as before, that I cant install (except for the -h command string).


    Today I cleaned again the whole system. After following the description in PDF I also used Windows Install Clean Up tool again. Further I searched for all files and folders on my main drive with the name of Tobii oder Tetserv oder Tetfw or whatever and deleted them, too. Than used CCleaner to delete all broken registry pathes. Than used the regscanner64 to search all traces of names with Tobii, Tetserver and Tetfw and deleted them, too.
    Still after restart: Tobii is already installed, installation aborted.

    There must be some reference which does not use any Tobii product reference in its name.
    Further as the developer you should specifically know for sure what references get checked on the setup file. Which are they ?
    Also some kind of way to force a full reinstall of the software would be helpful. Than I would not need to find any kind of traces and just freshly install everything by overwriting existing things.

    Please help !

    Grant [Tobii]

    hi @suppenkoch, very sorry to hear about your continuing difficulties. After internal analysis by our development team, it does appear that there is an issue with certains systems running the latest RS5 update to Windows 10 in conjunction with the current version of the Tobii Eye Tracking Core Software.

    We are actively working to identify the cause of the problem and rectify the situation. Thank you for your patience and apologies once more for your unfortunate experience.

    In the meantime, we can only recommend that for those systems affected, to roll back to a previous windows build until the issue has been resolved in a forthcoming installer version.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.