Home Forums Software Development C# OnGaze event not triggering

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #2384


    I’m trying to develop applications for a 3 years old quadriplegic friend of mine. I recently purchased the controller and dowloaded the libraries. Every single example works fine but the only ones I’m interested in. None of the GazeAware examples is working for me.
    I haven’t modified the code in any way apart from trying to build for 32 and 64bits and updating the dependencies to the 32/64bit dlls accordingly. Every other functionality works including the setup tools and even the asteroids game. So the problem is not with the device itself.

    I’m surely doing something wrong, but I cannot figure out what it is. Could someone please help?


    Hi Gonzalo,
    did I get you right that the (unmodified) samples don’t work on your machine?

    Here are some things you can try:

    1. Make sure that you’re using EyeX Engine 1.0 or later and EyeX SDK 1.0 or later.

    2. Run the EyeX Engine diagnostics application (Tobii.EyeX.Diagnostics.Application.exe; installed in the same directory as the EyeX Engine) while the sample app is running. Check if the gaze-aware interactors show up in the diagnostics window. (See this post for more info about the diagnostics tool.)

    3. Try the mouse emulation function (it’s also described in the post above) and see if it works. If it does, but it doesn’t with gaze, then your gaze signal might be too flickery for the gaze-aware behavior processor to pick it up. (Unlikely but not impossible).

    4. You can also see how the queries are handled by setting a breakpoint in the HandleQueryInner method on either the WpfEyeXHost or the FormsEyeXHost class (depending on your UI framework). Are the gaze-aware interactors added to the snapshot?

    5. If all else fails, try to set the Windows DPI to 100%. The samples *should* be DPI aware but it’s possible that we have missed some corner case.

    Good luck and please let us know how it works out!



    i tried all the things you suggested above with unsuccessful results. Diagnostics were working as expected, DPI was of 100. The mouse emulation did not really work, after commenting the line and re-staring nothing worked, blah blah blah…

    I was using:

    • Tobii.EyeX_1.1.0.4507-beta
    • TobiiEyeXSdk-DotNet-1.2.436

    Today I downloaded the following versions:

    • Tobii.EyeX_1.2.0.47
    • TobiiEyeXSdk-DotNet-1.3.443

    And everything worked as a charm!!! Pheeeauuww!! I was getting a little frustrated


    You have a wonderful product!


    I’m glad it worked out for you! 🙂

    If you have additional questions don’t hesitate to ask here on the forums.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.