Home Forums Software Development Calibration Failed: Firmware error

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #1634
    Deepak Akkil

    In my current eye tracking set up, I am using the EyeX in front of a TV (which is connected as an external display to the computer running windows).
    When i try calibrating the user, after the process , it says
    “Detection failed” .

    In the log file (present in C://Program Data/Tobii), for the calibration failure, it says:

    13:06:33 INFO CalibrationProcess: StartCalibrationProcessLoop calibration
    13:06:33 INFO CalibrationProcessViewModel: show stimuli – 0.5,0.5
    13:06:38 INFO CalibrationProcessViewModel: show stimuli – 0.9,0.5
    13:06:41 INFO CalibrationProcessViewModel: show stimuli – 0.9,0.1
    13:06:43 INFO CalibrationProcessViewModel: show stimuli – 0.5,0.1
    13:06:46 INFO CalibrationProcessViewModel: show stimuli – 0.1,0.1
    13:06:49 INFO CalibrationProcessViewModel: show stimuli – 0.1,0.5
    13:06:51 INFO CalibrationProcessViewModel: show stimuli – 0.1,0.9
    13:06:54 INFO CalibrationProcessViewModel: show stimuli – 0.5,0.9
    13:06:57 INFO CalibrationProcessViewModel: show stimuli – 0.9,0.9
    13:06:59 INFO CalibrationProcess: Computing calibration
    13:06:59 INFO CalibrationProcessViewModel: start computing result
    13:07:01 INFO CalibrationProcess: Failed calibration with
    exceptionTobii.Gaze.Core.EyeTrackerException: Firmware error:
    Operation failed. (error code FirmwareOperationFailed).
    Tobii.EyeTracking.Common.Calibration.CalibrationProcess.CalibrationProcessLoop(Uri eyeTrackerUrl, Point2D[] calibrationPoints, CancellationToken cancellationToken, Boolean
    13:07:01 INFO CalibrationProcessViewModel: calibration process
    completed, result – AllPointsFailed
    13:07:01 INFO CalibrationProcessViewModel: stop calibration process.
    13:07:01 INFO CalibrationProcess: Stop
    13:07:01 INFO Flow navigator: step –
    Tobii.EyeTracking.ControlPanel.Calibration.ViewModels.CalibrationProcessFailedResultViewModel, index – 3
    13:07:07 INFO CalibrationProcessFailedResultViewModel: Cancel
    13:07:07 INFO CalibrationViewModel: StopCalibration
    13:07:07 INFO EyesPositioningViewModel: Stop
    13:07:07 INFO EyesPositioningViewModel: Stopped
    13:07:07 INFO CalibrationProcessViewModel: stop
    13:07:07 INFO CalibrationProcessViewModel: stop calibration process
    skipped as no calibration process is active.
    13:07:07 ERROR CalibrationFlow: Calibration was aborted
    13:07:07 WARNING DiagnosticFlow: Recalibrate flow failed with error
    code Aborted

    Some Firmware error. I have checked that all the softwares and firmwares are up to date from the EyeX engine. I have checked with multiple EyeX trackers and both gives the same error. Any idea whats going wrong?


    Hi there,
    what EyeX version have you used?
    We did just recently release the latest version 0.10.xxx you can get it through auto-update or download it here: http://developer.tobii.com/eyex-setup/
    Included is actually also a new firmware, please try that and let me know if it makes any difference.



    Hi Deepak,
    with a stack trace like that it sure is a scary error message! But the reason for the “operation failed” could be as simple as that the tracker cannot detect your eyes. Have you checked out the eye tracker mounting guidelines?

    A related cause could be that the display area isn’t set up correctly, because that can lead to inferior tracking.


    Sorry for the x-referencing on the forum: http://developer.tobii.com/community/forums/topic/eyex-engine-calibration-fails/#post-1955

    May be related, I get the same error message. Although my colleague was able to calibrate successfully several times.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.