Home Forums Legacy SDKs Moved: Can't switch firmware


Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #567
    Stefan Reich


    We just received our Tobii REX. 🙂

    We are trying to switch the firmware to TCP through the EyeX SDK. We downloaded http://developer.tobii.com/?wpdmdl=19 and selected the rexdevlaptop_firmware_1.0.5.25169.20130705.1446.root.tobiipkg file in the upgrade dialog.

    EyeX complains: “The file you selected was not valid”.

    What’s going on? Please advise!


    Stefan Reich

    OK, I read somewhere in the forum that I should use fwupgrade32.exe. We tried that. And it crashes (“Application doesn’t work anymore”) after displaying that the package is supposedly valid.

    Why does this program crash? That’s not good.

    Also, what is the invocation syntax of fwupgrade32? Its syntax help is… cryptic. For the crash, we tried:

    fwupgrade32 tobiipkg rexdevlaptop_firmware_1.0.5.25169.20130705.1446.root.tobiipkg

    Please advise!!

    Jenny [Tobii]

    Hi Stefan!

    When trying to install the TCP firmware on the eye tracker, you are actually downgrading the firmware. This is not allowed to do from the EyeX settings dialog, since it should not be done under normal circumstances. That is why you got the “The file you selected was not valid” message.

    Since there are valid cases where you actually want to downgrade to the TCP firmware, such as when you want to use the eye tracker on Linux or Android, it is possible to perform a downgrade using the fwupgrade32.exe (on a Windows system :)).

    The fwupgrade32 is picky about its input and unfortunately crashes given the wrong input. (Which we of course should fix so that it doesn’t.)

    This is the syntax for downgrading the firmware:
    fwupgrade32.exe --auto <filename> --no-version-check

    The “–auto” flag means that it will run the upgrade/downgrade for the first eye tracker it finds connected to the computer, which works perfectly as long as you have only one eye tracker connected to the computer.

    I hope this helps!

    Stefan Reich

    Hi Jenny!

    Thanks for your answer. Yes you should best fix fwupgrade32 a little… 🙂

    But no worries if we can get it done. Will try ASAP.

    All the best,


    I am trying to use fwupgrade to switch FW from USB_HID to USB TCP/IP from TobiiGazeSdk-Tools- package, using Fedora19 64bit host.

    I can see the device with lsusb, but the fwupgrade can not talk to it:

    [TobiiGazeSdk-Tools-]$ lsusb -d 2104:0001
    Bus 003 Device 011: ID 2104:0001

    [TobiiGazeSdk-Tools-]$ ./fwupgrade –auto –info-only
    Tobii Firmware Upgrade Tool
    205 No eye tracker could be found
    No tracker connected

    Any ideas?


    Hi Stefan,
    the readout from lsusb tells me that your tracker has the USB-HID firmware on it. So you’ll need to switch to USB-TCP/IP.

    The bad news is that currently you cannot do that on a Linux machine, due to a device driver chicken-and-egg problem. But I hope you can find a Windows machine somewhere just for doing the switch.




    I have figured that part OK and now it connected and running kind of OK on my Linux box with USB-TCP/IP fw.

    The new problem I have is with tobii-analytics-sdk-3.0.83-ubuntu-amd64
    I have compiled the samples fine.
    I can connect to device fine with tobiictl.
    [tobiictl]$ ./tobiictl -i REXDL-010104612413
    Printing info about Eye Tracker: REXDL-010104612413
    Product ID: REXDL-010104612413
    Given name: REX_Dev_Laptop
    Model: REX_Dev_Laptop
    Status: ok

    The problem is that when I enable the tracking I get this error:
    [tobiictl]$ ./tobiictl -t REXDL-010104612413
    Tracking with Eye Tracker: REXDL-010104612413
    Connecting …
    Operation failed. 536872197

    Looking into documentation, I can see that means:

    Any suggestions?

    Robert [Tobii]

    Hi Stefan,

    I’m afraid the Analytics SDK is not compatible with the Tobii REX eye tracker. You need to migrate your code to use the Gaze SDK instead, or use an eye tracker that supports the Analytics SDK.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.