Home Forums Eye Tracking Devices Eye Detection Indicator stuck in Initializing

Viewing 11 posts - 31 through 41 (of 41 total)
  • Author
  • #4813
    Marc Pleijsier

    I have installed the newest drivers yesterday. Before that my tobiieyeX always was stuck on initialising but I could make it work by using USBDeview as a work around. Sadly this no longer works so I’m back at square one. I will try to fiddle with it some more when I’m back home. Is there a way to roll back drivers? I know there are old drivers for infinitescreen but would also like some for tobiieyeX drivers.

    Marc Pleijsier

    Hello everyone.

    I have fixed my problem my tobiieyex now starts up by itself after rebooting the machine.. (have to track if this will keep doing it as I tried it once).

    What I did was the following:

    Uninstall all drivers from Tobii (Including inifinite screen extension, just in case).
    Made sure it was removed from the device manager.
    Turned of the PC normally trough the shut down menu.
    Turned off the PSU (power supply unit) and left it off for a couple minutes, just to be sure.
    Left the USB3 cable in the PC but plugged it out of the tobiieyex.

    Turned the power back on on the PSU.
    Booted up the PC.
    Downloaded the newest Driver for the tobiieyex.
    Plugged in the Tobiieyex.
    Installed the driver software.

    What happened was that the drivers installed, it asked for the Hello update and than it started to update the firmware.
    Of course it might that one cause is not connected to the other but it worked for me. So maybe taking the full power off was the thing that made my PC think I did a new reinstall.

    My normal profiles were however still there but the tobiieyex now boots up on its own without the need to use a program like USBDeview which I did earlier.

    Currently running:
    Windows 10 HOME 64bit
    EyeX Controller
    FW: 2.0.2-33638
    Controller core version: 2.0.9
    Controller Driver version: 2.0.4
    Tobii Service version:
    Tobii EyeX Engine Version:
    Tobii EyeX Config version:
    Tobii EyeX Interaction version:

    Hope this maybe helps for those that also have or had problems.


    Milan Kubík

    Hey Marc
    I tried to do the same as you, but after a fresh install the software says that Tobii is connected to USB 2, although I am sure it is connected to USB 3 port that was working before. I am getting really tired of this… Any thoughts?

    Marc Pleijsier

    Well no exact thoughts as I don’t know what you already tried until now.

    Here follows some obvious stuff perhaps:

    >Have you tried a different USB-3 port?
    >Is there enough power for the USB-3 port?
    >MB firmware and USB Driver controllers up to date?

    Cant think of a couple other ones but these are to obvious perhaps.

    From experience I found that USB3 hubs and ports can be dodgy at times, and because not many products NEED USB3 yet and thus you mostly use it as a USB3 it can take a long while for you notice it is not working properly.

    Milan Kubík

    I tried every suggestion in this thread but non of those worked for me. The only solution for me is to uninstall everyhthing, restart PC, install the drivers with SentryInstaller from Steelseries webpage and then it works until I restart my PC again.


    So I think that the issue here is probably connected to the firmware update we’ve had some time ago on the device. Before that it worked perfectly for me, and now I’ve had these issues too. What helped me was to reinstall Tobii EyeX Drivers and let the device update firmware again.


    It used to complain nebulously about my USB 3 port, but it doesn’t do that anymore. Now it just does the forever-initializing thing. The red lights do come on when it’s trying to create the user profile, but otherwise, no workie.

    Could I ask that you up the geeky verbosity on your error messages and that you add a dead man’s switch for when it hangs too long and print out a geeky, verbose error message to offer us some clue as to what it was waiting on? Instrumentation ftw.

    Grant [Tobii]

    Hi Dave @ddt1234,

    Can you confirm if you have the latest firmware running on the device?

    Is there any other PC you can test with as well? Would be useful to know your motherboard and USB3 Chipset.


    I do not have another PC to test it with. I submitted a bug with a dump of the PC stats. The motherboard w/ the USB3 controller is an ASUS X99-M WS w/ the Intel X99 chipset.

    I looked in the Event Viewer, but I saw no messages at the time of what the failures are due to. Is there an error log stored in a text file somewhere?

    I have the latest drivers. I do not know how to check the version number of the installed firmware specifically.


    The only Tobii errors I’m seeing in the Event Viewer are complaining about not knowing where to find updates, which seems unrelated to my issue.

    I installed lsusb, and it doesn’t appear to recognize the device even at the USB level, nor does it show up anywhere in Device Manager. The three red lights do flash briefly when I plug it into a USB3 port, but that’s it.

    Is it possible I bricked it when I unknowingly interrupted the firmware update as I was trying different USB ports the first time I was installing it?

    Grant [Tobii]

    Hi Dave, thanks for the information. Certainly the device seems to be at issue here, so one of our support personnel will be in touch with you directly to see how we can proceed.

Viewing 11 posts - 31 through 41 (of 41 total)
  • You must be logged in to reply to this topic.