Home Forums Eye Tracking Devices Eye tracker 4c Disconnecting after a few minutes.

Viewing 13 posts - 16 through 28 (of 28 total)
  • Author
  • #9181

    I also getting this with a similar system on the latest bios but I do not have corsair software installed and USB power settings are off and bios is latest on my ASUS ROG CROSSHAIR VII HERO motherboard.

    Grant [Tobii]

    Hi @formant, sorry to hear about your issues… is restarting or reinstallation providing any solution or are you unable to connect to the device?

    This being the case, it would be worth raising a ticket with Tobii Tech support directly @ https://help.tobii.com/hc/en-us/requests/new who may be able to make further diagnoses upon receipt of diagnostic log data.

    I assume you have the latest Tobii Core Interaction Software installed also?


    Hi yes I downloaded the latest software. I will contact support.

    Grant [Tobii]

    OK thanks @formant, feel free to post again here should you find a solution that you think would be useful for our users. Best wishes.

    Grant [Tobii]

    Hi @jordan34, that’s great! Thanks so much for your valuable feedback, hopefully other users will find it of use 🙂


    I’ve recently started trying to use my 4C again and like the OP, I’m still getting random disconnects until the device stops working all together until I have to reboot the system to sometimes get it working again.

    In the Windows event viewer, the following Error Event ID 10016 occurs in direct correlation to the 4C attempting to connect and then subsequently disconnecting.

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
    and APPID
    to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

    I have tried giving the DCOM Configuration permission as outlined here: (process still applies to Windows 10)

    The other error that also occasionally occurs is:

    Faulting application name: Tobii.EyeX.Engine.exe, version:, time stamp: 0x5ae6bf76
    Faulting module name: tobii_stream_engine.DLL, version:, time stamp: 0x59f73c97
    Exception code: 0xc0000409
    Fault offset: 0x00087c24
    Faulting process id: 0x31f8
    Faulting application start time: 0x01d4e5484444770f
    Faulting application path: C:\Program Files (x86)\Tobii\Tobii EyeX\Tobii.EyeX.Engine.exe
    Faulting module path: C:\Program Files (x86)\Tobii\Tobii EyeX\tobii_stream_engine.DLL
    Report Id: 37c258df-16a1-4e0c-8ba1-4eb9ca2a7bd2
    Faulting package full name:
    Faulting package-relative application ID:


    From memory, these disconnection errors only seemed to start occurring when I updated to the Core Software 2.13 branch whenever that was released. The Core Software version that was available February 2018 did not have these issues.


    Just to add, after a restart and when the 4C is connected – it appears to be working fine at the desktop for an extended period of time. No disconnections, no errors in the event viewer.

    However as soon as a game is loaded, the disconnection issues begin. Sometimes it takes a few minutes and other times it occurs instantly.

    Even after quitting the games and returning to the desktop, the connection issue remains. The 4C lights up, but No Tracker Detected. The only way to regain ‘desktop’ functionality is to either uninstall and reinstall the Core Software or to do a system restart.

    If this were simply a hardware issue I’d expect that regaining ‘desktop’ functionality would not be possible upon every restart or be so replicable.


    Managed to ‘fix’ the 10016′ error, although all that did was suppress the warning in event viewer. That was a red herring.

    Today I changed the supplied USB 2.0 extension cable to a USB 3.0 one and connected it to the ASMedia 3.1 controller – and it worked fine. No disconnects.

    Swapped back over to the Intel USB 3.0 controller and it’s still working fine. No disconnects.

    The only other change I made was in the device manager:

    > Intel(R) USB 3.0 eXstensible Host Controller>Properties>Power Management> untick ‘Allow the computer to turn this device off to save power’

    Perhaps it was a bandwidth issue all along causing the disconnects.

    Grant [Tobii]

    Hi @patto, thanks for your detailed feedback and letting us know about the USB2 extension cable. I will raise this with the product owner and see investigate.. certainly it should not have made any difference as the 4C is a USB2 device so quite mysterious!

    So as I understand it now, there are no more disconnects now that you are using a USB3 extension cable connected to a USB3 port?


    That’s right Grant.

    The tracker is now indeed connected via a USB 3.0 extension cable connected to an intel USB 3.0 port and there are no disconnects.

    windows 10 OS Build 17134.648

    4C + USB 2.0 cable connected to USB 2.0 ports = disconnect
    4C + USB 2.0 cable connected to Intel USB 3.0 ports = disconnect
    4C + USB 2.0 cable connected to Asmedia USB 3.1 port = disconnect

    4C + USB 3.0 cable connected to USB 2.0 ports = disconnect
    4C + USB 3.0 cable connected to Intel USB 3.0 ports = Connect
    4C + USB 3.0 cable connected to Asmedia USB 3.1 port = Connect

    I simply don’t know why swapping the cable works. The USB 2.0 cable itself is fine – I have my xbox one controller connected to it with no issues.

    Grant [Tobii]

    Thanks for the extra info @patto, certainly I will pass it along. The issue we face here is reliably reproducing the disconnection problems itself as it does seem to vary from system to system. If you would care to include your full system HW specifications perhaps we can try to replicate in house.

    Glad to hear at least you have found a good solution for the disconnection issues and can get on with some eye tracking! 🙂

    AGP Studios

    Hey folks, I’m having this problem too.

    I do not have Corsair Utility Engine or any other Corsair products on my computer.

    I noticed that the lights stopped working and then my head tracking stops.

    I’ve come up with the following work around as a batch file (run as admin):

    @echo Off
    net stop “tobii service”
    taskkill /IM “Tobii Game Hub” /F
    net start “tobii service”

    I was getting tired of rebooting mid game. This fix works while the game is running and does not require rebooting (at least in Elite Dangerous).

    For the devs: I believe the issue is actually in the Game Hub, but restarting the service is still needed before running the Hub software. I hope this helps you find a fix. Also, I’m noticing this happens more when I’m wearing headphones and it has a more difficult time tracking my head movement when I’m wearing them.

    Grant [Tobii]

    Hi @agpstudios thank you very much for sharing your workaround and sorry to hear about your issues.

    Before sending to the developers, could you kindly confirm for me that you have the latest versions running of the both the Tobii Core Sofware and GameHub?
    We release new versions often, so it’s possible we had squashed this bug in a later release. Also, relevant systems specs would be good to know.

    Regarding the headphone tracking issue, which model are they? is there any shiny reflective surface facing the eye tracker? This could cause issue for tracking under such conditions. Best Wishes.

Viewing 13 posts - 16 through 28 (of 28 total)
  • You must be logged in to reply to this topic.