Home Forums Unreal Engine 4 SDK Eye Tracking Off-Center in Editor (Fix)

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #11616

    I created a new blueprint project targeting the desktop and extracted the Tobii UE4 SDK into the Plugins folder and I opened the DesktopExampleMap.

    When I attempt to play using Selected Viewport or New Editor Window, the eye tracking sphere is off-center towards the bottom right of where I am looking.

    When I play using Standalone Game, the eye tracking is accurate.

    Is there anything I can do to make the eye-tracking not get off-center when playing under Selected Viewport because there are some debugging techniques I can’t use in a standalone window?


    Hello there!

    Yes, this is fixed in the latest version of the SDK. We have been trying to get it out to you guys, but it has been delayed since many people are on vacation at the moment. I hope we can publish the version as soon as they are back however.

    The cause of the problem is the DPI setup. Basically, a while back we discovered that not having 100% DPI set on your monitor adversely interacts with the UE4 editor. I created a fix back then in the SDK, and also made a pull request for the engine itself. This pull request was accepted a while back which has meant that the correction is being done twice in the SDK (once by the engine fix, and one more time for the SDK patch that was put in place until the PR got in.)

    We have since removed the SDK patch, but as mentioned, that version is still not live.

    You can side step the problem by setting your monitor to 100% DPI.

    Let me know on discord if you need further help with this 🙂
    I’m “Temaran” over there.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.