Home Forums Software Development EyeX failed to initialize / Lack of support

Viewing 15 posts - 1 through 15 (of 24 total)
  • Author
  • #3568

    Guys, I’ve been trying to solve this problem for some time now. It’s getting a bit silly.

    My EyeX does not seem to want to work, it continues to be stuck at “Initializing”. I’ve tried everything suggested on the forum, in fact I’ve tried everything support suggested in emails.

    Tobii support even promised to do a remote session, multiple times. I made sure I’m in the office ready for them but they do not call, skype or email, just empty promises.

    What gives guys?


    FYI: Support finally got back to me. They have been trying to get it to work, so far unsuccessful. They are going to try some more tomorrow.


    You wouldn’t happen to be using the McAfee Suit for PC protection would you?

    Contacted Steelseries support about the same problem after getting my Steelseries Sentry last week.

    They suggested I register an RMA and then thy requested further information for shipping to replace the hardware, even tho the problem seemed to be in the device driver installtion, so I decided to take a closer look at the problem my self.

    The problem seems to be that the device ClassGUID used for “Eye Tracking Devices” in tobii_is3_device.inf is far from unique.
    In my registy there is already a class registered with ID {78a1c341-4539-11d3-b88d-00c04fad5171} and it seems to be for McAffe Process Start Notification Service that is part of the McAfee SiteAdvisor.

    Also after googling for 78a1c341-4539-11d3-b88d-00c04fad5171 i found the following that seems to indicate that the ID is from a driver code example in the Windows driver development kit:

    I suppose that Steelseries support will forward the information in a couple of days, but figured I post the information directly on the development forums to speed things up.


    I’ve now got my Sentry up and running after uninstalling McAfee Web Advisor. Uninstalling this did however not remove the class definitition in the registry. I had to go in using regedit and change the ownership of the registy key (and sub keys) for “HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{78A1C341-4539-11D3-B88D-00C04FAD5171}” to be able to manually remove them.
    And yes, reinstalling the Web Advisor puts these keys back and will block installtion of the Eyex/Sentry driver.

    Not sure if the Web Advisor is that critical since it is just a pre warning that maybe I should stay away from a site that seems to be doing stuff that other parts of the McAfee suit should catch anyway, but I’ll probably reinstall it as soon as I get a confirmation that the problem has been fixed from either Tobii/Steelseries or McAfee.

    Oops… copied wrong reg key name 🙂


    Unfortunately no, I don’t have McAfee. Support hasn’t figured anything out yet. 🙁

    Masta Lomaster

    Absolutely the same issue as CHRISTER OLSSON described.

    Spent a LOT of time trying to find a newer Intel USB3 driver with no luck.

    Finally found this post, found that the redistry key 78a1c341-4539-11d3-b88d-00c04fad5171 has “libusb” content in the computer where EyeX works, and has “mfesapsn” (McAfee) content in the computer where EyeX keeps initializing!

    Removed McAfee and the conflict key, reinstalled the EyeX software, now everything works OK (Thank you CHRISTER OLSSON a lot!!!)

    You definitely should avoid this not-unique UUID (universal UNIQUE id).



    I went in and removed that registry key, uninstalled Tobii Software restarted my machine, reinstalled latest Tobii software and still stuck at initializing.

    Jenny [Tobii]

    UPDATE – 21 Dec 2015: The latest EyeX software bundle comes with an updated EyeX Controller Driver 2.0.0 with a unique ID, which should resolve this issue.

    EDIT – 04 Jan 2016: My mistake – The fix for this McAffee issue was not included in the 2.0.0 driver, but another fix for Windows 10 which is suppose to help for some other “initializing” issue. See separate post below.


    Sorry still doesn’t work. Driver version / 10/14/2015

    I already had this exact same driver from the previous release. Did you forget to include the updated driver in the installer?

    Edit: yes I did the (driver) uninstall/reinstall/unplug/replug dance.


    From the device event log:

    Device USB\VID_2104&PID_0050\EYEX2-030145125532 could not be migrated.

    Last Device Instance Id: USB\VID_0781&PID_5581\A20053D30A493213
    Class Guid: {36FC9E60-C465-11CF-8056-444553540000}
    Location Path: PCIROOT(0)#PCI(1400)#USBROOT(0)#USB(6)
    Migration Rank: 0xF000FFFFFFFF0023
    Present: false
    Status: 0xC0000719

    Device USB\VID_2104&PID_0050\EYEX2-030145125532 was configured.

    Driver Name: oem130.inf
    Class Guid: {78A1C341-4539-11D3-B88D-00C04FAD5171}
    Driver Date: 10/14/2015
    Driver Version:
    Driver Provider: Tobii Technology AB
    Driver Section: USB_Install
    Driver Rank: 0xFF0001
    Matching Device Id: USB\VID_2104&PID_0050
    Outranked Drivers:
    Device Updated: false

    Device USB\VID_2104&PID_0050\EYEX2-030145125532 was started.

    Driver Name: oem130.inf
    Class Guid: {78A1C341-4539-11D3-B88D-00C04FAD5171}
    Service: WinUSB
    Lower Filters:
    Upper Filters:


    I am having similar issues, will not stop initializing and I’m not sure what is to actually be done once I’m in that part of the registry. What exactly do I click and disable/enable?

    Jenny [Tobii]

    I thought the new 2.0.0 EyeX Controller driver (with internal release date Oct 14 2015) included the fix for McAffee, but it did not. It included some other updates for the driver to work better on Windows 10.

    The fix for McAffee is planned to be included in the next EyeX software bundle release. For those of you who want to get access to this fix pre-release, let us know here and we’ll send the files and instructions to the e-mail address registered with your account here on the Tobii Developer Zone.

    Ron (@promixis),
    Even though you do not have McAffee installed, it might be that your issue is similar to the McAffee issue if there is some other software/driver that uses the same non-unique ID as the EyeX Controller on your system. I believe the fix for McAffee was to change to a unique ID for the EyeX Controller (though I haven’t been able to confirm this with my firmware colleagues just yet). Do you want me to send you the files with the fix so you can try it out?

    Megan (@mebessusn),
    The device can get stuck in initializing for more than one reason. Do you have McAffee installed on your system?


    I happy to test a build with a newer driver. Feel free to send it to me.

    Marc Pleijsier

    I fixed this issue very easy. I used USBDeview. It’s a freeware piece of software. Install it than open it and the tobiieyeX device. Right click the device and disable it. than right click again and enable it.
    After doing that the lights came back on and the device was ready to use.



    Hi Marc, thanks for the tip. I tried it but unfortunately that didn’t help in my case. I still can’t use the eye tracker.

Viewing 15 posts - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.