Home Forums Eye Tracking Devices Moved: "Could not connect to eye tracker"

Viewing 15 posts - 1 through 15 (of 74 total)
  • Author
  • #770

    That program doesn’t recognize the EyeX Controller at all for me. “Could not connect to eye tracker.” it says. I don’t know what to do with it. :/

    Jenny [Tobii]

    Hi Joona-Petteri,

    I moved your reply to a topic of its own since it deserves a thread of its own.

    Here is a general list of reasons why the EyeX Settings panel would show a “Could not connect to eye tracker” message:

    – The eye tracker is actually not plugged in to the computer
    – The eye tracker driver is missing or needs updating
    – The driver installation failed for some reason
    – The eye tracker firmware is being updated (should display message)
    – The EyeX Controller is not connected to a correctly working USB 3.0 port (for more info see our Support page)

    If you think it may be due to driver issues, try uninstalling EyeX and re-installing with the latest EyeX Software.


    I’ve done all that couple of times, even restarted computer after uninstall and installing. It makes a sound and flashes 2 red lights on the product, then it tries to update firmware, after a little while the update windows disappears without any notification.

    -ALL the drivers are also checked, I tested it by intentionally miss a driver when it instantly gave a notice that something’s wrong.
    -USB 3.0 checked since the program tells if it’s on 2.0.

    Robert [Tobii]

    @jomppeeee: Just to check, what does it say on the About section in EyeX settings:

    On my computer I have a working EyeX Controller with the following versions:
    – Firmware version: 0.9.12-29489
    – Tobii USB Service version:
    – Tobii EyeX Controller Driver version:
    – Tobii EyeX Controller Service version: 0.9.7
    – Tobii EyeX version:


    I got it somewhat working when I tried to change windows from 7 to 8.1, now the only issue is calibration where usb times out every time

    Robert: The versions are exactly the same for me now

    Oscar Andersson

    I have the same problem. It flashes red when connected, and it’s in the device manager, but the Tobii software can not seems to find it.
    Not sure about how much power is needed from the usb-ports, but I can run my Oculus Rift via USB so hopefully it’s powerful enough?
    I have the same numbers as Robert in the About section, except Firmware Version is blank (because it couldn’t find the EyeX and install the firmware)

    I’m not really willing to upgrade to 8.1 for this to work :/


    I’ve managed to find out something about this issue, it’s definitely that “asmedia USB 3.0 eXtensible Host Controller – 0096 (Microsoft)” but i can’t find a WORKING one to replace that one :/ it’s not related to Tobii products at all (i googled it a big while and everybody seems to have similiar issues with usb3.0)

    The other driver i used with windows 7 (most likely the same Oscar got at the moment) didn’t react at all

    Oscar Andersson

    I managed to fix it!
    The USB driver I use is called “Renesas Electronics USB 3.0” or something like that. I thought I had the latest version, because I had downloaded the “latest version” from the support page of my motherboard (thanks, ASUS). But I managed to find an even newer version, which fixed everything. 🙂


    I have the same Problem – “Searching for eye tracker” but not found.
    There is a red light blinking on the right side of the tracker, but the Settings tell me “Could not connect to eye tracker”.
    The tracker appears as usb device, the Firmware updater says that there is nothing to update.
    I tried to update the usb3.0 Driver, but it has also the newest Version.
    I am using a PCI connected USB3.0 Card.
    Any ideas?


    i also received my Eyetracker last week and i’m stuck with the same problem, when connecting the device to my USB3 port (on my Dell XPS l502) the bar flashes once and then goed black. meanwile the software cant connect to the device.


    Now i tried another Computer.
    Using Win7 i had no luck – the device was not detected.
    Using Win8.1 on same Computer: the eyex was detected and installed, calibration started but when trying to follow the dot the device connection was lost.

    Seems that the eyex is not a ready product.


    There’s some compatibility issue it seems, though with powered usb hub I actually managed to get it ALMOST fully working, now it only crashes the usb driver AFTER the calibration 🙂

    Videojocs Adaptats

    I’ve bought a PCI Epress usb3 card (Conceptronic C4USB3EXI) and the eyetracker drivers say thats conected to an USB 2.0 port.
    Any idea what can I do?

    Robert [Tobii]

    Hi, there seems to be a lot of issues with USB3 drivers and compatibility. The moderators of this forum are software developers and do not have the knowledge to help you with this kind of troubleshooting. Please check out the Support page where we have collected some FAQ info related to USB3 and have a list of recommended PCI cards etc. If the FAQ info doesn’t help you, there is also a link to contact technical support.

    Dennis Lo

    ASmedia’s USB 3 controller is a bit flaky when in comes to USB3 compatibility even with other devices. I am running my EyeX using the USB3 controller integrated in the Intel HM77 chipset and the connection seems to be fine so far.

Viewing 15 posts - 1 through 15 (of 74 total)
  • You must be logged in to reply to this topic.