Home Forums Eye Tracking Devices Moved: "Could not connect to eye tracker"

Viewing 15 posts - 16 through 30 (of 74 total)
  • Author
  • #855

    It would help if you could give us some hints which usb3.0 hubs work.


    while there are times when my eye-x doesn’t connect at all, at other times the check calibration button brings up the tracker lights and everything functions as required, but goes back to disconnected mode once the calibration window is closed. The program defines the eye tracker state as offline and no other settings bring the track lights back on, except for a brief second when connecting the device


    also, the tracker always works in the showcase setup


    Today i received an active usb3.0 hub. On my win8 computer the lights flash shortly when connecting, no more reaction. On my win7 computer i get the message that i connected on a usb2.0.
    Seems that the eyex is not a working product….

    Davy Loots

    I have the same problem: the lights flash briefly, after that nothing. After installing new USB drivers and rebooting a few times, the device worked for 10 minutes (perhaps by coincidence), after that only sporadically after unplugging it.
    I have used the Kinect v2 with heavy USB 3.0 requirements without problems on this pc.

    Mattias [Tobii]

    @Karthik. The eye tracker will only light up when there is a program or application that listens to a data stream from the eye tracker. Could it be that there is no application requesting gaze data ? It seems like it gives data when requested (like showcase and during calibration). Test the EyeX setting panel button check Calibration. Also here it should jump into life.

    Mattias [Tobii]

    @Davy. It sounds like an odd problem. Could it be that same issue that Kathik is seeing and if so are you sure that some application is listening to data? Test by calibrating for example. If it really is a connection issue it seems that something must have happened to the device (as you explain it working at first). If so please contact Tobii support.

    Mattias [Tobii]

    @Andreas, This is somewhat odd. Are you running an early version of the EyeX engine perhaps? Incorrect assessment of USB 2/USB 3 was supposedly fixed in the 0.8.14 release. I assume that you are sure that both the hub and the computer port is USB 3, since otherwise it will not work. What sort of System are you using? (desktop or laptop?).


    I followed this discussion since I had a similar problem. My computer is from late 2010 so my motherboard doesn’t have USB 3.0 controller. I had an extension card installed from the very beginning though. It’s a Digitus A-30220-1 with a NEC D720200 chipset on it (http://www.digitus.info/sv/produkter/archiv/2-port-usb-30-pci-express-karte-ds-30220-1/). When plugging in the EyeX, all drivers were recognized properly but the EyeX settings panel wouldn’t be able to connect to the tracker.

    What I did was update not only the driver but also the firmware for my chipset. NEC is now called Renesas – finding drivers for this older model on their site was impossible.

    station-drivers.com has a pretty complete collection though: http://www.station-drivers.com/index.php/downloads/Drivers/Renesas-Nec/USB-3.0/

    So I downloaded controller firmware version and the WHQL driver and rebooted. Connecting the EyeX resulted in the updating firmware dialog again (which was there before) but it again vanished without any information. I then re-connected the EyeX cable again and suddenly the windows driver dialog would show that the Tobii Flasher Program was being installed and from there on i got the tracker to light up and work.

    So I guess the crucial part is to find out the chipset of your USB controller and then get the latest driver and/or firmware for it. If it’s on your motherboard you should get the information about the controller from the tech specs on the vendor website.


    Hi all,
    yes, it is matter of fact sometimes a little bit tricky to find the right driver for the USB controller.

    As an example:
    If you have a Renesas(NEC) USB3.0 Controller, the official Driver on the mainboard manufactures website is V2.0.32.0.
    V2.0.32.0 is though, not the latest and is not working with all USB 3 devices, e.g. the Tobii EyeX Controller.
    If you now have a closer look on google, you will see that Intel has a Renesas (NEC) USB3.0 Controller driver version V2.1. V2.1 is working just fine.

    Most of the mainboard or computer manufacturer are just not adding the latest drivers to their websites anymore, as they are not “supporting” those products anymore. So it is important to check exactly what USB 3 controller is in use and look for the latest driver.

    Davy Loots

    Thanks, after installing the intel drivers the device seems to work great (Windows 8.1)!
    Here is the direct link to the drivers I used:



    I tried to use the EyeX on different hosts under Windows 8.1 (classic desktops, HP laptop, even on a Macbook Pro with VMWare). Installation is ok on all configurations. When I plugged the device on 2.0 USB port I got the right message to find a 3.0 port. When plugged on 3.0, everything seems to be ok. Then calibration can be sometimes fully done but every 30 or 60 seconds the Eye-X turns off and is disconnected. It connects again 15 seconds later but not for more than one minute. If I launch Tobbi Showcase demo, EyeX disconnects in less than 3 seconds.

    I tried to use a 3.0 powered USB HUB and got the same behaviors.

    Current versions are:
    Firmware 0.9.12-29489
    USB service
    EyeX Ctrl Driver 0.9.3
    EyeX Ctrl Service 0.9.7

    Any idea of the possible cause ? Lack of power (mA) on USB port ?

    Regards, Philippe.

    Mattias [Tobii]

    Hi Philippe,

    Thanks for your post. We have seen your specific problem (connecting but then disconnecting after 30-60 sec) on a few eyetrackers from the first batch and it seems you may have such a unit (At least this is what I think when I read your post). We are trying to solve it with the next firmware upgrade, but are still digging into it. Either stay tuned, try on another host system altogether (some host systems are more forgiving towards these units) or Contact our support as they may have more tips and tricks. Powered hubs may work depending on the inner working of the hub, but the problem itself has actually nothing to do with supplied mA, but rather how they filter certain communication on the link. Right now we have no real good list of usb 3.0 hubs that do this as we are working on solving the problem at the core. Of course there has also been very good posters here on the forum so checking out this thread from time to time for tips is a also not a bad idea, even more so as the community grows every day. And remember that you are always welcome to contact our support team.

    Hope this helps, or at least know that we are trying to attack the problem and we are thankful for your input.

    Mike Kasprzak

    No luck getting the Tobii working on Windows 7 64bit. It keeps telling me my USB 3.0 ports are USB 2.0. Mine is an Asus motherboard (M5A99X EVO R2.0) with an ASMedia 104x USB 3.0 controller. Asus latest drivers are from 2011, but I scoured the internet for some drivers from 2012 and 2013. Those also had no effect. There was also a BIOS setting, disable legacy USB 3.0 support, also no effect. I’m having no luck with ASMedia controllers.

    samuel adams

    i have found the latest drivers for my usb 3.0 pci e card i bought on amazon (anker)

    online, i installed those drivers which were listed for win 7 64 bit.
    after installation i checked my device manager and confirmed no ! issues.

    when looking at device manager and universal serial bus controller i can confirm it says usb 3.0…

    It keeps telling me my USB 3.0 ports are USB 2.0 so I have a brick and don’t know what to do.

Viewing 15 posts - 16 through 30 (of 74 total)
  • You must be logged in to reply to this topic.