Home Forums Eye Tracking Devices Moved: "Could not connect to eye tracker"

Viewing 14 posts - 61 through 74 (of 74 total)
  • Author
  • #1256
    Mattias [Tobii]

    Hi Dennis,

    We have seen some issues for AMD processors that we think are related to a not up to date libusb library that we are using. This could very well be what you see. We have a fix coming up in a coming release, however this is still some time away before it is rolled out. Please contact our support and they can guide you and give you something that hopefully will help sort out your problem.


    James Stout

    Heads up: the new engine update broke things for me again. I ended up reinstalling the previous version and now things work again. With the most recent version, again I saw the firmware update window every time I plugged the device in, but I wasn’t able to get around it with the “sleep hack” from my previous post.

    Andrew Sanocki

    By chance would you happen to know where I could get a older copy of the software? I just got mine today and I have getting the same issues as listed above. When I check for firmware status and such it appears it is not even applying the update/reading the device is hooked up. I have updated my usb3.0 drivers (They are intel) and still no luck. I have fully tested my usb 3.0 ports with 2 3.0 USB Hard drives both pulling well over 125mb/s during transfers.

    This is on a windows 7 x64 box. Any help would be greatly appreciated.

    James Stout

    Perhaps the Tobii folks could help with this? I just had the old version lying around.

    Andrew Sanocki

    Thanks James Hopefully we can get something figured out on this, I was really looking foreword to working with the hardware but sadly just some issues today it seems.


    Hi guys!
    Actually I don’t really see any relation between the EyeX version and the actual connection.

    , your problem seems like one, many other people experienced, a non existing connection, right?
    In this case, it would help quite a lot if you tell me/us, what controller exactly you have. There are quite a lot of different Intel drivers out there, without having any clue what adapter you have, I’d guess you need the driver version


    Andrew Sanocki

    Hey Konstatin, I installed the driver last night for my system (Still not working, reinstalled twice to make sure it is in fact updating). https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=21129 I am using a Asrock mobo http://www.asrock.com/mb/Intel/Z77%20Extreme4/

    I have updated the drivers, the only reason I was asking about the old software was one of the requirements was a updated firmware on the device. Seeing as I just got my device from the box, I was wondering if it was possibly just not able to update to the newest firmware and thus not connecting.

    Also Seeing as James said he was having a issue yet the older software was working for him I felt seeing if that was a viable workaround for me currently would not hurt anything.

    Not really sure what else I can try on my end, I guess I could try loading *shivers* windows 8.1 and see if a dual boot would fix it so I can work with the device. But I would be sad if that is the required fix for this.

    Figured I would attach a screenshot of my driver status for you, Not sure why it says the driver date is from 2013, but it is in fact the right version as you suggested http://i.imgur.com/pS7NgRY.png

    Andrew Sanocki

    So guys I think my issue might possibly be software related. I got windows to see my Device. But the software just wont play ball.

    So windows sees it just fine, But the software just cant find it.

    Andrew Sanocki

    So it has been nearly a week and no reply on this? By chance can I get the older software download link? That is all I am currently requesting to see if that fixes my issue. as you can see from above I have gotten windows to fully see the eyeX


    Hi there,
    sry for the late reply, but July is a tricky month in Sweden.

    However, I actually can’t post any link here in the forum, as they would only be temporarily anyways, ad then I’d need to repost once or twice a week..

    So instead, I’d ask you to contact our support directly: http://developer.tobii.com/support/

    However, it’s quite essential that you send us your log files as well!!
    C:\ProgramData\Tobii – > InstallationGuide, Tobii.Configuration,
    C:\ProgramData\Tobii\Tobii Interaction -> latest ServerLog
    C:\ProgramData\TetServer -> serviceLog.0



    Jenny [Tobii]

    Hi Andrew,

    For the sake of having important information distributed in this thread, I’d like to point some things out here, though you may receive this information and help from our support team.

    In the screen shot of USB controllers (http://i.imgur.com/pS7NgRY.png) you provided above, one can see that there are actually two USB 3.0 controllers on your system.

    Except the “Intel(R) USB 3.0 eXtensible Host Controller”, there is also a “ASMedia XHCI Controller”. Maybe one comes with the mother board, and that the other with an externally connected USB 3.0 port, like a PCI card.

    So, the first important thing is to decide which USB 3.0 controller governs the USB 3.0 port the EyeX Controller is connected to.

    Unfortunately, if it is the ASMedia XHCI Controller, this is a known issue with no solution at the moment. Tobii EyeX uses libusb to access the EyeX Controller, but it seems the ASMedia USB 3.0 drivers do not respond correctly when libusb requests information about connected devices. The request fails with an error that there are no connected devices. We have been in contact with both libusb and ASMedia developers about this issue.

    In your case, though, if you have another USB 3.0 port, that is governed by the Intel(R) USB 3.0 eXtensible Host Controller, the EyeX Controller may actually work with that port.

    (For those who just jumped in on this thread: This is a problem seen on Windows 7, where each USB 3.0 port manufacturer have to provide their own USB 3.0 driver and root hub driver, and these drivers are not consistently implemented. In Windows 8, Microsoft provides a generic USB 3.0 stack.)

    James Stout

    Some more data to help with debugging: for the second time, I managed to get things working on my older computer by performing the firmware upgrade on a newer computer. So the problem is clearly in the firmware upgrade process.


    After trying several usb 3.0 pci cards i bought the HP QT587AA card.
    And – it works!
    I also tried the eyex on a HP computer at work – i got it running there too.
    Seems that HP hardware is a good base for the eyex….

    T. Azuhata

    Finally, EyeX works with using a SilverStone SST-EC04-P card.
    PC: EPSON Endeavor Pro7500 (Win8.1)

Viewing 14 posts - 61 through 74 (of 74 total)
  • You must be logged in to reply to this topic.