[Solved] Solution to EyeX unable to set-up (generic monitor issue)

Home Forums Software Development [Solved] Solution to EyeX unable to set-up (generic monitor issue)

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #5233

    Hello everyone,

    First of all, I want to give all of my appreciation to the Tobii Team for all the work they’ve put on the EyeX and on the development of Eye Tracking technologies in general. Thank you very much!

    Now to the issue at point: there is currently a little issue which might occur when you have a monitor without drivers and try to set up EyeX because, well, you can’t (if you have TeamViewer).

    Let me summarize the problem and the solution below:

    Issue: EyeX can’t be set up for a particular monitor when the monitor doesn’t have drivers and TeamViewer is installed (if that’s the only monitor, EyeX can’t be set up at all).

    Replicating the issue:
    1.- Have a monitor without drivers (e.g. Asus for W10) so it will show up as Generic monitor.
    2.- Install TeamViewer. It will replace the monitor’s generic drivers with TeamViewer drivers.
    3.- Select the Change Display option of the EyeX Engine.
    Result.- Set up screen doesn’t show up or shows up only in monitors with non-TeamViewer drivers.

    1.- No explanation required.
    2.- EyeX ignores TeamViewer monitors because they aren’t supposed to be real monitors. Unfortunately, TeamViewer overrides physical monitor’s drivers (at least the ones without actual drivers) somehow or under some conditions (e.g. it might only happen when upgrading from W8.1 to W10 while having TeamViewer installed and a generic monitor).
    3.- No explanation required.

    In Windows Manager Select the corresponding monitor (it will probably say PnP-Monitor and it’s properties will say the Manufacturer is TeamViewer GmbH). Go to its Properties, then to the Driver tab, then to Update Driver, then to “Browse for driver software on your computer”, then “Let me pick from a list…” and select Generic PnP Monitor; finish the wizard and the problem should be solved.

    This way, the driver goes back to the Generic PnP Monitor which is not a TeamViewer driver and therefore, EyeX recognizes the device as a physical monitor.

    PS. Sorry if this isn’t the correct Forum, I couldn’t quite figure out where this fit the most.

    Grant [Tobii]

    Hi @rgaribay,

    Thank you so much for these tips! Hopefully future users will find it useful.


    It seems there is a time-frame for editing posts, so I’ll include a slight change here:

    “In Windows Manager Select the corresponding monitor”
    “In Windows’ Device Manager select the corresponding monitor”

    Also, I want to point out something Emelie, who answered my support request, made me realize:
    This issue only occurs when a remote TeamViewer connection, at any point in the past, requested to “show a black screen locally” and accepted the installation of the driver necessary for that functionality. This means that although the usage of TeamViewer might not be a rare scenario, this issue should not be as common.

    Again, from Emelie; uninstalling/reinstalling TeamViewer is an easy solution for the non-tech-savvy.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.