Home Forums Eye Tracking Devices Tobii REX Not Working with Windows 8.1


Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #3507
    Dillon Lohr


    I have the Tobii REX for Developers, and I cannot seem to get it working with my computer running Windows 8.1. It will not initialize with Tobii EyeX, and it appears in the Device Manager under “Other devices” as “Tobii IS Eye Tracker”. According to http://developer.tobii.com/rex-firmware/, this means that the firmware is running the USB-TCP/IP variant and my computer is missing the drivers.

    I installed the “Tobii USB Service 1.3.2 – for Windows” (assuming this is the driver I need; is there any other driver on the downloads page?) and ran the various dpinst applications in the subfolders of the Tobii folder in the program files which appeared to install drivers (if running those applications was even necessary–I am desperate at this point). I have tried using the fwupgrade tool in the GazeSDK to update the firmware, but running “fwupgrade –auto –info-only” returns “205 No eye tracker could be found No tracker connected”, as does “fwupgrade –auto rex_fw_1.2.4.tobiipkg” (I downloaded “Tobii REX Firmware 1.2.4 – for USB-HID”, the only firmware I could find on the downloads page, and shortened its name).

    At this point, I am completely lost. Are there other drivers or firmware I should have downloaded instead? If so, where are they located? The ones I got were the only ones I could find on http://developer.tobii.com/downloads/. Did I install the driver incorrectly? Am I using the fwupgrade tool incorrectly?

    Thank you in advance, I don’t know why I am having such a difficult time getting this to work.


    Try installing the following driver: https://www.filecentral.se/filecentral/app/en/pub-downloadForm.html?uuid=5b2544c7-32ad-45cc-a71f-31f9ef56d6a2
    The link though, is , so it will only be available for the next 48 hrs….
    However, afterwards, you will be able to upgrade the FW using “fwupgrade…”


    Dillon Lohr


    First, I want to thank you very much for providing that driver, because both EyeX and fwupgrade recognize the Tobii REX, now! However, running the fwupgrade command now returns this:

    “Tobii Firmware Upgrade Tool
    Automatically selected eye tracker tet-tcp://
    Valid Tobii package for g5
    Package mismatch”

    According to the Gaze SDK tools documentation, this means that the firmware is incompatible with my device. However, I downloaded the only firmware for the REX I could find on http://developer.tobii.com/downloads/ (1.2.4 for USB-HID). Is there another firmware I should be using instead? If it helps, the REX is currently using firmware version

    Just for completion’s sake, I also tried upgrading the firmware using EyeX, but it states, “It seems that the eye tracker is not plugged in. Make sure it is plugged in during the whole upgrade process,” even though the REX remains plugged in the whole time.

    Thank you.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.