dev [Solved] Unity development pre-build offset

Home Forums Software Development dev [Solved] Unity development pre-build offset

Tagged: , , ,

This topic contains 3 replies, has 2 voices, and was last updated by  Jenny [Tobii] 1 year, 8 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #5869

    Benedikt Mayer
    Participant

    When I develop an application for windows using unity the Gaze is always offset to the top left corner.
    I tried setting my DPI to 125% / 100% instead of 100%, but nothing changes.
    Same for discovering the focused object via “GetFocusedObject()”, it doesn’t yield any reasonable results.
    I don’t use any UI elements.
    I have recalibrated the device and it works otherwise.
    It suddenly works after building the application, but I can’t build every time I make a change.
    The same is true for the example project with the spinning cube. It only works after building, never inside unity.
    I’m using a windows 10 laptop with the newest unity and eyex software.

    #5875

    Jenny [Tobii]
    Moderator

    Hi Benedikt (@banjo),

    Since it works in standalone but not in the Unity Editor it does very much sound like a DPI issue. Windows 10 automatically sets a high DPI on high resolution screens so it is a bit tricky to change the correct DPI setting to override this behavior.

    First, try changing the compatibility setting for the Unity Editor:
    – Locate the Unity.exe file in a file explorer (probably located in something like C:\Program Files\Unity\Editor\)
    – Right click the exe and open Properties
    – Go to the Compatibility tab
    – In the Settings section, check the “Disable display scaling on high DPI settings”

    If that doesn’t work, try to set a custom DPI scaling level for all displays in Control Panel:
    http://www.tenforums.com/tutorials/5990-dpi-scaling-level-displays-change-windows-10-a.html#option2
    Use the Step 5 option and select a value of 125% (or 100%) DPI.

    I hope this will resolve the issue!

    #5876

    Benedikt Mayer
    Participant

    Hi!

    Changing the compatability settings for the Unity Editor worked like a charm.

    Thank you so much!

    #5878

    Jenny [Tobii]
    Moderator

    Great news! Thanks for letting me know it worked out for you.
    (And I should probably update our troubleshooting guide to include the compatibility setting as a preferred workaround as well :))

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.