dev [Solved] Unity Wont Build SDK Scenes

Home Forums Software Development dev [Solved] Unity Wont Build SDK Scenes

This topic contains 14 replies, has 8 voices, and was last updated by  Alex [Tobii] 1 year, 1 month ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #6422

    george lawton
    Participant

    I tried building the scenes that came with the SDK and got the following error:

    error CS1703: An assembly `Tobii.EyeX.Client.Net20′ with the same identity has already been imported. Consider removing one of the references
    Assets/Tobii/Plugins/x86_64/Tobii.EyeX.Client.Net20.dll (Location of the symbol related to previous error)
    Assets/Tobii/Plugins/x86/Tobii.EyeX.Client.Net20.dll (Location of the symbol related to previous error)

    How do I fix this?

    #6443

    Jenny [Tobii]
    Moderator

    Hi George (@glawton),

    I’ve seen this problem from time to time. Usually it disappears after I’ve done the following: checked in the Inspector for the files above that one is set to 64 bit and the other to 32 bit, made sure build settings was set to PC, Mac & Linux Standalone – Target Platform: Windows, restarted Unity Editor.

    We are working on an updated Unity SDK that will not have this problem. Would you be interested in a pre-release version of this SDK? I could e-mail it to the e-mail address registered with your login here.

    /Jenny

    #6445

    george lawton
    Participant

    Yes, I would be interested in the pre-release version of the updated SDK.

    Thanks,
    George

    #6474

    Joakim Larsson
    Participant

    Hi Jenny (@jennytobii)

    I also have the same problem and would be interested in the pre-release version.

    Thanks,
    Joakim

    #6475

    Alex [Tobii]
    Keymaster
    #6478

    Joakim Larsson
    Participant

    Thanks @alex8b, that solved my problem!

    #6491

    george lawton
    Participant

    That worked, but only when I set the target to x86_64. Thanks!

    #6528

    Alex [Tobii]
    Keymaster

    Hi! I sent you a new beta package on email.

    #6633

    Anonymous

    Hello Jenny (@jennytobii),

    could you send me the new SDK too, please?
    Getting the same error.

    Thanks,
    Michael

    #6638

    Alex [Tobii]
    Keymaster

    Hi!

    Please check this temporary solution here:

    http://developer.tobii.com/community/forums/topic/how-can-i-get-eyeposition-by-unity-sdk/

    We are working hard to release an update.

    #6705

    Christine Payne
    Participant

    Hi @jennytobii
    I’m also having the same problem & would love the pre-release version. I tried following the steps you described, but have not had luck.

    -Christine

    #6708

    Alex [Tobii]
    Keymaster

    Hi!

    I will send a beta package to your email tomorrow.

    #6838

    Ahmed Al-Hulaibi
    Participant

    Hi,

    I’m also having the same problem. I tried the temporary solution and the issue persists. Would it be possible to receive the beta version?

    #6853

    Grant [Tobii]
    Moderator

    Hi @bluefrostgames, the package is almost ready to be release (either this week or next) so we wont send out any more Beta code.

    Please check back on the site regularly over the next few days.

    In the meantime, the documentation is up and you can check it out @
    https://tobii.github.io/UnitySDK/manual

    #6861

    Alex [Tobii]
    Keymaster

    Tobii Unity SDK for Desktop 3.0 Beta:

    Download:
    https://github.com/Tobii/UnitySDK/releases

    Documentation:
    https://tobii.github.io/UnitySDK/

    Please feel free to send us your feedback.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.