Home Forums Software Development USB connection loss

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #14162

    Anyone got idea about USB loss connection loss with code 43?
    restart the laptop fix the issue. However, it always loss connection in device manager after around 20 mins usage. Reinstall the driver and all sort of solution found online, never resolve. Could it be a hardward problem?

    Grant [Tobii]

    Hi @matthewchen, sorry to hear about your issues. The first thing I would suggest would be to ensure you have installed the latest version of the USB Chipset and BIOS for your system and of course fully updated Windows 10.

    Can you confirm if this behaviour is persistent on other USB ports also? It would also be a good idea to look at your power settings in both the device manager of the USB hub in question (and in general Control panel settings) to see if the power to the 4C is being reduced automatically.

    Please go through these steps and let me know how you get on. Best Wishes.


    I don’t understand why my post lost so I write it again
    First of all, I am using an alienware m15 r2, so the eyechip is built in
    I am pretty sure about the software. The bios is up to date. I download the driver and the tobii experience from dell tech support website. I am pretty sure is the mort recent version. So have tried to uninstall the driver and the tobii experience and uninstall it. Does not work. I also tried to use the dell os recovery to reset the whole system, does not work too. I also go to the device manager to uninstall and re-install the device, does not work. I also disable and re-enable it, does not work too.

    It’s very very strange condition. Sometime if I reboot the laptop, everything back to normal. Yet with a round 30 mins usage, the eye chip begin to lost connection, In the device manager, either showing up error sign in the eye chip saying that the system can not start the device or simply detect a unknow usb device with error code 43.

    I am pretty sure I am not alone. I found similar case in another dude also using m15 r2. And I found the same issue in a post two years ago regarding the ROG monitor. Tons of people have the similar issue.

    One strange thing I found out is that the driver of eye chip in device manage has a strange data — 4/21/2006. People with similar case have the same driver date. Not sure if it is common for normal condition.

    I don’t expect any support from dell unless a hard-core developer in Tobii decide to look down to it. This bug sitting out there since 2016 as I could found online. All we could expect from the tech support is telling you to reinstall driver software etc. And people like us have tried every single method we could find but just doesn’t work…..

    I wish maybe I could raise a little bit attention here.

    If it is not a hardware issue, than I believe that this bug may sit there for many year. It maybe a very deep bug in the driver.

    I am not sure if’s the hardware issue, given the fact that every time I boost up the laptop, I have around 60% to get the eye chip work again, but just a very short time.

    Please report this to the developer team.

    Grant [Tobii]

    Hi @matthewchen, okay thanks for the clarification. Given the nature of the hardware, the best approach would be to get in touch with Tobii Tech Support directly (if you have not already done so) whereupon they should be able to arrange a remote session and gather diagnostic data on the device and let you know the best way to proceed.

    You can raise a ticket @ https://help.tobii.com/hc/en-us/requests/new

    Best of luck resolving your issue.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.