vjoy and infinitescreen software problems

Home Forums Game Integration vjoy and infinitescreen software problems

Viewing 15 posts - 1 through 15 (of 36 total)
  • Author
  • #4068

    hi guys, i just recieved the eyex and all works perfectly except for the infinitescreen app. when i installed i got an error that vjoy could not get intalled and when i open infinitescreen it gives me an error telling me that it´s unable to connect to the eyex engine.
    any idea on how to fix this?

    Joe K

    I just received mine as well and am getting the same exact problem.”vjoy failed to install” just as the installation finishes. Immediately afterward it says that the setup is complete.

    Then when trying to run the extension I’m given the message “Unable to connect to the EyeX engine. Please make sure that Tobii Eyex Engine is running and that the eye tracker is connected.”


    exactly what i´m getting. i tried everything i know of to fix it. let´s hope some dev gets in touch with us or i´m gonna have to ask for a refund and get something more reliable like a trackir.


    Joe, did manage to fix it??



    We’re working on a solution for this problem. Until then, here are two things you try that might help resolve the issue:

    – Make sure that you do not have a previous installation of vJoy (check under Program and Features). Uninstall and reboot if you do.

    – During the vJoy-installation. Uncheck all of the the “Companion Applications” (Demo vJoy Feeder application, vJoy Configuration application, vJoy Monitoring application) before continuing the installation.

    – After you’ve installed the Infinite Screen Extension and had the vJoy installer fail – download and install vJoy version 2.0.5 (Infinite Screen Extension installs vJoy 2.1.6). It’s available for download here: http://sourceforge.net/projects/vjoystick/files/Beta%202.x/2.0.5-120515/
    (again, unchecking the optional vJoy-components during installation might help).

    Which versions of Windows are you using?


    hi henrik,

    i have already tried all of the above but i will once more just in case.
    i´m using windows 10 64bits
    i have to say that the first time i tried to install the infinitescreen software, right when it was installing vjoy i got a blue screen of death, wich i supose totaly messed up the vjoy part but i of course uninstalled it all and tried to delete all vjoy related things.

    i´ll let you know,


    Im having the same issues. I tried the suggested above to no avail. I’m wondering if there are any registries i need to remove before i try a fresh install attempt.


    hello again henrik
    i finally managed to install vjoy 2.0.5 also vjoy 2.1.6 on their own but when i install infinitescreen and fails to install vjoy and when i try to open it i keep getting unable to connect to the eyex engine. please make sure that tobii eyex engine is running and that the eye tracker is connected´´ wich it is connected and working i have the three red leds, it´s calibrated and works perfectly in windows.


    Having exactly the same issue here. Running Windows 10 64 bit. Initial vjoy install with Infinite Screen didn’t complete (simply hung for an hour at 50%). Subsequent attempts at uninstalling and reinstalling have failed, even using 2.0.5 as suggested above.

    Any update on this issue? Just received the device today and can’t use it without this being fixed. :-]

    Stephen Wolters

    I am having the same issue also. Can’t run it in Elite Dangerous without this being fixed. Please give us a fix ASAP.


    yeah, didn´t get it to work either i just sent in today for a refund. i really hope you get it to work cause it´s a wonderfull product especially for disabled but it´s such an assel to make it work.


    I cannot get mine to work at all on infinite screen. Once I install and run Infinite screen it says ‘Could not initialise infinite screen extension’

    At the same time it kills my x52pro

    I have removed the x52pro completely, reinstalled all the Tobii bits and still the same issue with the ‘Could not Initialize’ error message. I am running windows 10 64bit.

    Tobii software works fine, I can calibrate etc etc

    Keith Thomas

    Same thing for me It cant seem to find vjoy under win 10 from what I see in the logs

    Jeremy Jacobson

    I have the same problem. I have spent the last 4 days trying to get mine to work. I can get it to work in demos but it will not interface with vjoy. I have tried the newest drivers, the old ones mention above and nothing I do gets this working in Elite dangerous. I returned my Irtrack 5 for this and starting to feel that was a mistake.

    I also have an X52 Pro that I believe is conflicting in some way with Vjoy. Each time I install Vjoy I notice the lights on my throttle go out. (Lights on the flight stick stay on). When in screen extensions and I try to set the enable disable key or the screen centering option it always says Joystick 27 + (my key choice). Not sure if Joystick 27 is Vjoy or my X52. When I remove the X52 and drivers from the system Joystick 27 goes away and I can Select just my key choice.

    Other things I have tried, uninstalling and reinstalling elite dangerous and ED: Horizons. I have tried manually changing my bindings in the config file.

    One thing I noticed in Vjoy monitor, X,Y and Z all have a red input level of 50% that never change. If I have the X52 removed then inputs 1 to 8 are also discovered. With the X52 installed no inputs are checked and only X and Y have input levels in red.

    I am about to pack this up and request a refund, this is pretty ridiculous how much time I have wasted trying to get something that should work out of the box working.

    Jeremy Jacobson

    Tried the recommended reinstall with out companion addons… still doesn’t work. Tried everything in admin mode… doesn’t work.

    Uninstalled ALL Saitek X52 Drivers, Tobii eyeX drivers, Vjoy Drivers
    unplugged all input devices accepts keyboard and mouse
    reinstalled Tobii eyeX drivers and software
    installed Infinite screen extensions (installed happily no problem) no addons
    Loaded elite dangerous and checked configuration.
    Still doesn’t work.

Viewing 15 posts - 1 through 15 (of 36 total)
  • You must be logged in to reply to this topic.