[Solved] Same Unity project does not work on different computers

Home Forums Game Integration [Solved] Same Unity project does not work on different computers

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #5175

    Hi everyone!
    I made a game with Unity 5.3.2f1 on a computer of my university and never had any problem with EyeX. Today I tried to use the same game on two different computers (with same version of Unity) and I got this error message when I started the game:

    EyeX initialization failed because the client access library 'Tobii.EyeX.Client.dll' could not be loaded. Please make sure that it is present in the Unity project directory. You can find it in the SDK package, in the lib/x86 directory. (Currently only Windows is supported.)
    EyeXHost:InitializeEyeX() (at Assets/Standard Assets/EyeXFramework/EyeXHost.cs:472)
    EyeXHost:Start() (at Assets/Standard Assets/EyeXFramework/EyeXHost.cs:219)

    I have already found some discussions where the same error message, but they were in different contexts (i.e. updating Unity) and these solution did not work for me. I have tried to reimport the whole package and to delete the dll file in the root of the project, but it did not really change.

    Any help with it?
    Thanks a lot in advance! 🙂



    How did you transfer the project? Did you copy the entire project folder, or did you clone it using git or some other scc software?

    It looks from the error that the client dll did not survive the transfer, so one thing you can do is check that all the EyeX framework scripts and plugin dlls are still present under Assets/*.

    You could also try reimporting the EyeX Unity package on the other computers, since that might also fix the problem if the problems are a result of a bad copy 🙂



    Hi Temaran,
    Sorry for the late reply!

    I found out that it was my fault. I actually forgot to install Visual Studio in the computers where I was testing the game.
    But I have to admit that the error message in the logs it was a little bit misleading… 🙂

    Hope anyway that the topic can be useful for future reference! Thanks for the support!


    Hehe, good to hear it worked out at least 🙂

    Have fun!


Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.