Home Forums Eye Tracking Devices Tobii shutting down/cutting out

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #9219

    I have an Acer Nitro V17 laptop with a Tobii device installed. This piece of hardware shuts down as though the power has gone out to the Tobii unit after a very short time after a power up / reboot.

    With my latest test of the unit after it had failed again. I switched the laptop off and waited two hours before powering back up. When it booted up and loaded Windows 10 I saw the red lights on the Tobii tracker sensor for a couple of minutes. However before I had a chance to do anything with the laptop the Tobii lights went out and the Tobii software stated that there was; ‘No eye tracker connected’. Then without warning the Tobii’s red lights came on again briefly for a couple of seconds and went out again….never to be seen again in this round of rebooting.

    Before you ask…yes…I have all the latest drivers and bios installed.

    I noticed that I am not the only person that is having these problems. It seems to me as if the power draw on the system by the Tobii is too high for the laptop to handle when other peripherals such as my Saitek X52 Pro, Logitech G402 mouse and cooling pad are all operating at the same time. This sort of defeats the purpose of having the Tobii as part of this system and has basically rendered the Tobii dead until reboot.

    If you need any further information just ask and I shall endeavor to assist as I want this hardware to function as it should and not just be another piece of unstable technology that is basically useless.

    I want this hardware working. I play Elite Dangerous and I have only had it running for a very brief period of time (2 or 3 mins) in the game before the lights go out and my unstable little friend dies another death.

    Please do ask me for whatever information you need. I await your answers, updates, fixes or patches.


    As a further piece of information for you I was looking at the Device Manager. Under USB Controllers there was one that reads Unknown USB Device (Device Descriptor Request Failed). The device status had this message:

    Windows has stopped this device because it has reported problems. (Code 43)

    A request for the USB device descriptor failed.

    In Device Manager if you go to View and check Show Hidden Devices the Universal Serial Bus devices then also appears. Under this there is EyeChip. EyeChip device status has this message

    Currently, this hardware device is not connected to the computer. (Code 45)

    To fix this problem, reconnect this hardware device to the computer.

    Hope this assists your devs in solving this problem for me and others that have the same issue.


    And a further update. Upon uninstalling each of the ‘faulty’ USB devices and EyeChip driver profiles and doing a reboot. The system automatically reinstalls these drivers and they operate without problem for a few minutes before they suddenly revert to their former status as detailed above. I am currently using the ‘gaze’ function to see how long it lasts before the unit ceases to work again. Hopefully it just settles down an keeps working this time.

    So thats it guys and gals…here’s hoping that the devs can find a solution to this annoying problem.


    I jumped into the discord and got this answer from a helpful user and so far it seems to have solved the issue!

    Sometimes it is necessary to perform a clean reinstallation of the Tobii Core software if something has gone wrong or files have become corrupt. To perform a reinstallation, please do the following:

    – Uninstall the Tobii Core software through Programs and Features
    – Open up Device Manager and remove the relevant hardware, but do not allow the machine to reboot yet:
    — For a 4C/IS4 platform, find the USB Devices section, then remove the EyeChip device
    — For an EyeX/IS3 platform, find the Eye Tracking Devices section, then remove the EyeX Controller device

    – Open the registry editor (in a Run box, type regedit and click OK) and then delete the following keys:
    — HKEY_LOCAL_MACHINE => SOFTWARE => WOW6432Node => Tobii

    – In a normal file browser window’s address bar, type %localappdata% and delete any folders labelled Tobii and TetServer
    – In a normal file browser window’s address bar, type %programdata% and delete any folders labelled Tobii and TetServer
    – Restart your computer and allow it to install the EyeChip driver again
    – Repair all versions of Microsoft Visual C++ Redistributable that you have installed – you can do this from the Programs and Features menu by selecting each one, clicking on Modify and choosing Repair
    – Ensure that you have both Microsoft .NET Framework 4.5 and Microsoft Visual C++ Redistributable 2015 packages installed – get these from Microsoft directly if they do not appear in the Programs and Features list
    – Download the latest version of the relevant Tobii Core software from http://gaming.tobii.com/getstarted
    – Install the software as normal, and check to see if this resolves your issue

    Cheers! Hope it works for others too with a similar problem.

    Grant [Tobii]

    Hi @donatelllo, sorry to hear about all your troubles but thanks so much for the detailed fault and solution information, this should hopefully prove very helpful for any other users experiencing similar issues.

    Very glad to hear you think the situation has been resolved following a complete reinstallation of the Tobii Software.

    Please don’t hesitate to get in touch again should this or any other problems resurface. Best wishes.


    Thanks Grant. I hate to say it but the problem has resurfaced. However I believe I now know the true problem. It is the cable connecting the built in Tobii in my Acer Nitro VN793G laptop to the motherboard.

    I thought that the cable might need re seating and carefully took the laptop back off and did so. The problem disappeared and the Tobii worked for quite a number of hours before dropping out again this morning. I believe that due to the positioning of the cable in the laptop it is being affected by heat. Basically a bad design on Acer’s part.

    This cable has this written on its tag: Neptune Eyetracking 450.0B107.0011

    Any ideas where I can buy one as a replacement? I really do not want to go to Acer as they have customer service equivalent to a flying house brick.

    Appreciate any info you or anyone else can provide. Cheers.

    Grant [Tobii]

    Hi @donatelllo, thanks for the feedback and sorry to hear that the issue is ultimately hardware related. I am afraid we do not provide replacement components of this type and that accordingly you will indeed need to speak with Acer who (assuming the warranty is still valid) should be able to help you out. Apologies for the inconvenience.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.