Home Forums Software Development [Solved] Unity development pre-build offset Reply To: [Solved] Unity development pre-build offset

Jenny [Tobii]

Hi Benedikt (@banjo),

Since it works in standalone but not in the Unity Editor it does very much sound like a DPI issue. Windows 10 automatically sets a high DPI on high resolution screens so it is a bit tricky to change the correct DPI setting to override this behavior.

First, try changing the compatibility setting for the Unity Editor:
– Locate the Unity.exe file in a file explorer (probably located in something like C:\Program Files\Unity\Editor\)
– Right click the exe and open Properties
– Go to the Compatibility tab
– In the Settings section, check the “Disable display scaling on high DPI settings”

If that doesn’t work, try to set a custom DPI scaling level for all displays in Control Panel:
Use the Step 5 option and select a value of 125% (or 100%) DPI.

I hope this will resolve the issue!