Home Forums Software Development EyeX Samples for .NET not working

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #1025


    I have downloaded the TobiiEyeXSdk-DotNet and tried to launch the samples in my VisualStudio 2012.

    None of the samples actually worked for me. All of them either stop working after like 1 second of being launched or fail with “vshost32.exe has stopped working” error. I do not see any errors in console, nor while debugging. The applications just exit even when standing on a breakpoint in the debugging mode. Sometimes I see the UI window being launched, but then it just closes in a second or so when application exits.

    Some output from the console says the following before the applications exit:
    The connection state is now TryingToConnect.
    The connection state is now Connected.

    Am I doing something wrong?
    I basically havent changed anything in the samples code. I have imported the whole solution, built it and trying to run. There are no reported errors nor warnings.

    Thank you in advance,



    UPDATE: the issue was resolved by installing the newest version of the Tobii EyeX Engine [http://developer.tobii.com/eyex-setup/]. Even though the existing version was not so old, installed in the beginning of the year.
    Could mention this requirement in the documentation for .NET SDK.

    Robert [Tobii]

    Hi Veronika,

    Great that you found the solution to the problem. We mention EyeX Engine compatibility in the readme file of each package, e.g. “This version of the EyeX SDK requires EyeX Engine version 0.8.14 or later.”, but we should probably be even more clear to avoid misunderstandings.

    Note that the EyeX Engine and SDK are still under heavy development, and new releases will continue to be available through the auto-update function in the EyeX settings panel. We expect at least one more API change that will require EyeX SDK developers to adjust their code a bit. We’ll do our best to communicate when this will happen through as many channels as possible.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.