Home Forums Eye Tracking Devices Moved: "Could not connect to eye tracker"

Viewing 15 posts - 46 through 60 (of 74 total)
  • Author
  • #1028

    Just installed another usb 3.0 pci Card (Inateck KTU3FR-4P, full powered, compliant to usb standards) – but no positive result.
    First the old message “you have a usb 2.0…”, than no more messages but “waiting for the eye tracker…”.
    The eyex is a wired device that only works with a few usb 3.0 cards… seems not to be usable with standard devices.
    Is it a software/Firmware Problem?
    Hope so because i really want to play around with the eyex and not send it back.

    Mattias [Tobii]

    Hi Andreas,

    Sorry to hea about your continued troubles. The USB 3.0 card you mention (Inateck KTU3FR-4P) is not a card that we have tested in house so there could of course be some incompatibility problem. I do not know the brand of your previous card, and there is of course the risk that that card also is incompatible (double unlucky). Have you tried with one of the USB 3.0 cards that we recommend, or on a computer with native USB 3.0?

    Since you have already tried with updated drivers, it seems like that is not the problem. My guess is that either you have been unlucky with both of your selected cards or there may be some malfunction with the device (eyetracker or cable) that you have. It would be one of very few hardware malfunctions reported but you may of course be unlucky in that respect.

    We are ordering the USB card you are using so that our Q/A team can test it in house, but the result from that will take a little time.

    In the meantime I can really only suggest three things, either wait for our test of your USB 3 card, or try your device with one of our recommeded cards (because then it should work no problem if the hardware is ok) or contact our support for a replacement unit. However if it turns out to still be something about the USB card, the exchange will not help.

    Mattias [Tobii]

    Hi Michele,

    We will look into this. Thanks for reporting.


    Hi Mattias!

    I have ordered the Sandberg pci card – i hope you will replace my eyex with no additional cost if it does not work with the sandberg pci card.
    Btw. If you want ordinary pc users to work with the eyex you should improve the eyex to work with all usb 3.0 cards – I think only developers and freaks are willed and able to try different cards.



    Hi Andreas,

    I’m quite convinced that you won’t experience any further problems, when switching to the Sandberg card.
    However, if not, our Support team will contact you and obviously send you a new device, for free.



    I have tried three different USB 3.0 controllers and none of them have worked so far. I have tried the AsMedia 1042 with latest driver of and it says “The Tobii EyeX Controller requires a USB3.0 port. It seems as it is connected to a USB 2.0 port.” I tried the recommended Silverstone Silverstone SST-EC04-P and it hung at installing firmware. I returned that one and purchased the HP USB 3.0 2×2 SuperSpeed PCIe x1 QT587AA. I upgraded the driver to latest version from TI website http://www.ti.com/product/tusb7340 This one also froze at installing firmware. At this point, is there anything else I can try?


    Hi there,
    that’s quite strange and unfortunate indeed.
    Let’s try like this…

    Connect the EyeX to a USB 2.0 port (USB 2.0 is good enough to upgrade the firmware) wait until the firmware upgrade has gone through and a “wrong connected… USB 2.0..” error message pops up.

    Now connect it the the HP USB 3.0 controller again.

    Videojocs Adaptats

    Here with the 2nd effort…
    I’ve tested too with appPCI2P3V2 card with VL801-Q8 chipset and still detected as USB2.0.
    I’ve updated with the last drivers from aqprox! the manufacturer and the same luck.
    With the last drivers from via-labs the same http://via-labs.com/en/support/downloads.jsp#hostdriver
    I’ve tested them in 3 computers…
    Tobii EyeX seems to be really tricky with the USB3.0 controllers.
    I think that I will order some of the recomended PCI-X cards and Iwill have less problems and more productive.


    I hope you have luck.

    I bought the sandberg pci card but still “Cannot connect to eye tracker…”.
    Seems to upload the Firmware when starting/plugging the eyex in, but i think it only tries to do so. When starting the settings application it is still waiting for the eye tracker.
    The “TheEyeTribe” tracker works without any problem – but hoped to be able to try the eyex too.


    @Konstantin I tried to plug it into a USB 2.0 port and I got an error message that said it must be plugged into a USB 3.0 port. When I click ok nothing happens. It does not try to update the firmware. Can I manually run the firmware update somehow?


    Hi everybody,
    ok, let’s have a look at this…

    So everybody still has problems, even after using one of the recommended cards.
    In this case we should make sure to quickly figure out if this is a hw problem or driver problem.

    So the firmware-upgrade needs to be done the very first time you connect it to the PC, this can though, take a little while…
    You should see the windows, mentioning the update, also the EyeX should blink…

    If this fails, I’d suggest to connect it to another USB port.

    While it’s connected, I’d love to know if and how it’s recognized in the device manager, maybe you two could send me a screenshot from the device manager “libusb” find the email address here: http://developer.tobii.com/support/

    Also, please attach the log files to the email, “%programdata%”: InstallationGuide, Tobii.Configuration, Tobii.EyeX.Settings

    As a quick explanation…
    The EyeX is a true USB 3.0 device and requires a USB 3.0 connection. Other devices e.g. a usb memory stick or hard-drive etc. are pretty much always backwards compatible and can run a USB 2.0 connection, so instead of getting a error message, they just get slower.



    Hi again,
    also… did you connect power to the pci cards? They do need it…



    Yeah power and libusb are there. I filed a ticket on your form but there was no way to attach a screenshot.

    James Stout

    I ran into similar problems as other posters and found a simple workaround. If, after connecting the eye tracker and waiting for the firmware update screen to go away, I sleep my computer, then wake it, it works (consistently).

    Before finding this, I updated my USB 3.0 drivers, tried a powered USB 3.0 hub, but nothing worked. I’m using a laptop so adding a new card was not an option. Note that my laptop is a few years old and must have a pretty early USB 3.0 port, because it is not blue (although it does say SS).

    Also, when I plugged it into a newer computer, it worked right away (after the firmware update screen), and since then it has worked normally on my first computer. Also notable that now my “remove hardware safely” pop up correctly identifies the device. Before it gave some generic name.

    Adam Leighton

    Hi there, like many others, I have had no luck trying to connect my EyeX – USB3.0 not recognized.
    I have a ASUS AM1M-A motherboard (a new system I purchased especially for the USB3.0 to connect the EyeX), with the latest driver as far as I can tell. The driver is AMD
    usb 3.0 eXtensible Host Controller 0100 (Microsoft) ver:6.3.9600.16506.

    What can I do?

Viewing 15 posts - 46 through 60 (of 74 total)
  • You must be logged in to reply to this topic.