[Solved] Setting UIAccess to true hinders eyex program

Home Forums Software Development [Solved] Setting UIAccess to true hinders eyex program

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #5068

    Hello everyone,

    I am trying to include the magnifying API from windows into my EyeX program. For this I need to set some Linker properties within the Manifest File.

    UAC Execution Level: highestAvailable(/level=’highestAvailable’)
    UAC Bypass UI Protection: Yes (/uiAccess=’true’)

    However, whenever I change these settings in my program (based on MinimalGaze Sample) it cannot be run. I get an error saying the reference analysis was send back by the server.

    Any ideas how I can include it within my program or is it not possible to include accessibility-functions from the Windows API within my eye tracking?

    Thanks for your replys.

    Grant [Tobii]

    Hi @szs-vanessa,

    Could you kindly explain in more detail regarding the error:

    Such as where the error message is generated from, which component it’s coming from
    and whether or not it still occurs when EyeX is running.

    As much info as possible will help us in trying to resolve this issue as there should
    not be any limitations of this fashion we are aware of.


    Hello Tobii Team,
    the problem described has been solved by simply setting the runtime environment to x64 and then the Magnification API is happy to run without the parameters described in the manifest file. I found out about this issue last weekend. Sometimes it can be so easy, but thank you anyway for your reply.

    Kind regards,

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.