Home Forums Eye Tracking Devices Updated to windows 10, having trouble setting up EyeX device

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #3591
    Jim MacKenzie

    I used my eyeX just fine under windows 8.1, but after updating to 10 its just not working correctly.

    I installed the software, and it automatically updated the firmware on my eyex, and now instead of running it just constantly connects and disconnects endlessly. Is this the result of a bad firmware flash? Or a missing driver? Or is it just not supported under windows 10?

    René Pulejo

    I have the exact same problem … I had to uninstall everything to avoid continuous crash on Windows 10. I hope soon tobii make a driver update.


    Me too 🙁
    It worked fine for about some weeks, but now it continously connects/disconnects – really annoying.
    Is there any chance to get rid of this?

    Best regards


    Pradipta Biswas

    In my case, Tobii EyeX failed to start and the red lights on the eye gaze tracker are not on.

    Jenny [Tobii]

    Hi all,

    We have identified a problem in the EyeX Controller Driver with Windows 10. We have a new driver (version 2.0.0) pending to be released with the next public EyeX Bundle release. Please contact support to get a hold of this updated driver beforehand: http://www.tobii.com/xperience/support/contact/

    Pradipta Biswas

    I did the following

    1. Edited the registry and moved Tobii from WOW6432 to under Software in HKEY_Local_Machine/Software

    2. Edited the permission of Tobii and gave Full Control to local user

    3. Restarted Tobii Service from Service Manager

    Now it is working fine again.

    salvatore tramonte

    Hello I have the same problem, please could you better explain how you moved from WOW6432 to HKEY_Local_Machine/Software?

    Pradipta Biswas

    Hi Salvatore

    Go to regedit

    Select Tobii from WOW6432

    Right Click and select Export

    Save it somewhere and open it with Notepad

    Replace the word WOW6432/ by /

    Save the file

    Go to regedit

    Import the file

    -Hope that helps

    Sunu Wibirama

    I tried to follow Pradipta’s suggestion, but it did not work.
    In my case, I cannot start calibration. Soon after the first target appeared, it stopped and the controller disconnected.

    I used Windows 10 with EyeXController:
    Firmware version: 1.8.2-33290
    EyeX Controller Core Version: 1.8.1
    EyeX Controller Driver Version: 1.3.1

    Does anybody have a hint to solve this problem ?

    Pradipta Biswas

    Hi Sunu

    After the tracker is disconnected, please check if the Tobii Service is still running or not ?


    Sunu Wibirama

    Yes, Tobii Service was still running, i just checked.

    By the way, I modified the registry entry, so that
    this line:

    is it correct?

    Pradipta Biswas

    I did not change individual registry entry but mine one is also HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Tobii\EyeXConfig\EyeTrackers\tet-tcp://

    Please check the permission level


    Is there any news to this? Running on W10, having constant disconnects as described above.
    I upgraded to W10 from W8 but only got the EyeX afterwards.

    Already tried changing registry entries, but didn’t help anything.

    Firmware version: 2.0.2-33638
    EyeX Controller Core Version: 2.0.9
    EyeX Controller Driver Version: 2.0.4

    Also sending some data to support if it lets me this time.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.