Home Forums Unity SDK Gaze indicator random lag

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #21608


    I’ve been using the Tobii eyetracking in a University project for several years without a problem. Last week we started woking on a new project and used the old Unity project as a base. Unfortunately we now see a big lag of around 1 second in the response of the gaze indicator when moving our eyes, but at other moments it responds fine. And we actually see the same behaviour in the original application now as well.

    So we are wondering what is causing this beheviour, especially since we modified nothing in the old project. We tried it on 2 laptops and a desktop PC, no difference. We used two Vive Pro Eye headsets, no difference. So I think we can rule out a hardware issue. I also tried it with a disabled virus checker, but that also made no difference.

    The software we have:
    Unity: 2019_2_17f1
    TobbiXR SDK: v1.8.0 (I saw that you’re up to version 3, but since this worked fine for the original project, I see no problem in staying on this version)
    Tobii runtime, as part of the Vive SRanipal: VR4U2P2
    Vive SRanipal SDK:
    Vive SRanipal runtime:

    The only difference I can think of between then and now is that a Windows update may be causing this behaviour. Or can the Tobii runtime have been upgraded in the background without a notification to the user?

    Has anyone seen this as well? Any thoughts on how to fix this?


    Grant [Tobii]

    Hi @joostbos, I realise the reluctance but if you could try to use the most recent XR SDK version (& Unity if possible) , also updating the SRanipal SDK ..thereafter we could see about reproducibility and if the issue persists. Best Wishes.


    I tried to upgrade the project, but it’s a mess now.

    In my original project I have two folders, TobiiXR and TobiiPro and the package is not listed in the Package Manager (makes sense, this is from before the Package Manager).

    When I delete both TobiiXR and TobiiPro in Windows Explorer, not in Unity, open Unity and then import the 3.0 SDK package, I get several compile erors. So I restarted Unity, but the errors remain, for example:
    C:\VR\Tobii SDK\Runtime\Core\Helpers\XRDisplaySubSystemHelper.cs(11,46): error CS0246: The type or namespace name ‘XRDisplaySubsystem’ could not be found (are you missing a using directive or an assembly reference?)
    Library\PackageCache\[email protected]\Editor\XRGeneralBuildProcessor.cs(162,33): error CS0234: The type or namespace name ‘BootOptions’ does not exist in the namespace ‘UnityEditor.XR’ (are you missing an assembly reference?)

    This is in Unity2019.2.17f1

    Since you recommend 2019.4.5 for SDK 3.0 I started again, upgrade the project to 2019.4.13, as that is the Unity version I have.
    Also no Tobii XR SDk in the package list. Did the same steps, removed TobiiXR and TobiiPro and iported the SDK 3.0 package and again compile errors:
    Error: Could not load signature of Tobii.Research.Unity.CalibrationThread:get_EyeTrackerIF due to: Could not load file or assembly ‘Tobii.Research.Mono, Version=, Culture=neutral, PublicKeyToken=70326046dcdce6cb’ or one of its dependencies. assembly:Tobii.Research.Mono, Version=, Culture=neutral, PublicKeyToken=70326046dcdce6cb type:<unknown type> member:(null) signature:<none>

    Restarted Unity, still compile errors:
    Assets\Scripts\GazeVisualizer.cs(3,13): error CS0234: The type or namespace name ‘Research’ does not exist in the namespace ‘Tobii’ (are you missing an assembly reference?)

    Copied the folder TobiiPro back from my backup and restarted UNity and then I got the meesage that I needed to switch to the XR plugin system.

    Now the compile errors ar gone, but the gaze visualizer does not move at all anymore. I don’t see errors, so I have no clue what is happening. I see a debug statment:
    Tobii eyetracking input value: True
    But I don’t see the G2OM message that I saw before.

    So I’m completely lost about what’s happening and if this has solved my problem.
    Hope you can help me out.



    I figured I should try one of the sample scenes, to see if they work. Installed the getting started section and opened the Example_gettingStarted.

    I immediately noticed a missing prefab (the first object in the scene hierarchy) and when I started the scene nothing happened with the Gaze Focussable Objects.

    So I hope the missing prefab gives you an indication about what’s wrong.

    Grant [Tobii]

    Hi @joostbos, as the Tobii XR SDK is a free product and you are using the now deprecated and unsupported HTC Vive Eye Pro, I am afraid our resources are limited to deal with this particular query. I would suggest looking at if there is a lag using purely the SRanipal SDK to see if the issue does indeed lie at the Tobii level or HTC Level.

    The getting started scenes work directly out of the box, with no modification needed, so it might also be worth trying on a new system just to check.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.