Home Forums Legacy SDKs Samsung Galaxy Tab 4 and Gaze SDK


Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #2461


    I have problem with communication with Tobii Rex and samsung galaxy tab 4. First of all I installed EyeX on windows 7 (for fun and tests), but unfortunately that software was unable to establish connection with eye tracker – stuck in initialization (on the other hand message in cloud was “Eye tracker Connected”). After some tries and recconecting initialization finished successfully. Eye tracker was working. I checked firmware “type” and it was USB-HID. In next step I successfully switch firmware from USB-HID to USB-TCP in order to connect eye tracker to android device. And problem with never ending initialization again appears and I have no idea how to deal with this. Also I tried to run MinimalTracker sample code and function tobiigaze_get_connected_eye_tracker always returns 205 – no matter if I set parameter to –auto, tet-tcp:// or even tet-usb://<serial number>. When I tried to connect eye tracker to samsung galaxy tab 4 this function returns the same value – 205. The most important for me is communication with samsung galaxy tab 4 (android version: 4.4.2 without root rights).

    And addition to this I can’t return to USB-HID firmware – firmware update tool result is always:
    Tobii Firmware Upgrade Tool
    205 No eye tracker could be found
    No tracker connected

    I will be grateful for any help…


    If you want to use the Tobii Rex as TCP/IP device on Windows, an additional driver is required.
    Tobii IS Drivers 1.3.5 – for USB TCP/IP – http://developer.tobii.com/?wpdmdl=18

    If you still experience connection issues, please contact our support as they will need to provide you with different files: http://www.tobii.com/eyex-support




    I observed a strange issue using fwupgrade tool. When I’m trying to change Tobii Rex firmware from TCP to HID with parameter tet-tcp:// then whole upgrade process goes properly (finishes with success). On the other hand when I’m trying to switch firmware from HID to TCP with tet-usb://serial_number as a parameter I get as result: Connect error.

    However, when I’m trying to change firmware from HID to TCP with parameter tet-usb://M14K090101 then upgrade finishes with a success. I’m wondering why I have to use such a strange value instead of serial number. Is it hardcoded or something like that?

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.