Home Forums Software Development Can't install core software

Viewing 15 posts - 16 through 30 (of 32 total)
  • Author
  • #8023

    I have the same problem.

    What I did since:
    1) Trying a clean install with the tutorial through the website with no luck (stopps every time at 94%)
    2) Trying to stop avast while installing with no luck
    3) Trying the windows configurability mode with win7, which at least got me a decent failure report, but that doesn’t help at all (and it doesn’t even start to install, but tells me about the framework issue further down)

    This is the log:

    [2594:0B24][2018-03-20T09:43:06]i001: Burn v3.10.2.2516, Windows v6.1 (Build 7600: Service Pack 0), path: C:\Users\lafru\AppData\Local\Temp\{2FD62A5E-1702-4A5F-86BE-B6D45C72004F}\.cr\Tobii_Eye_Tracking_Core_v2.13.0.7241_x86.exe
    [2594:0B24][2018-03-20T09:43:06]i000: Initializing string variable 'PRODUCTTITLE' to value 'Tobii Eye Tracking'
    [2594:0B24][2018-03-20T09:43:06]i000: Initializing string variable 'EULA_FLAG_PATH' to value 'SOFTWARE\Tobii\License'
    [2594:0B24][2018-03-20T09:43:06]i000: Initializing string variable 'EULA_ACCEPTED_VALUE' to value 'AcknowledgedEulaVersion'
    [2594:0B24][2018-03-20T09:43:06]i000: Initializing string variable 'EULA_INSTALLED_VALUE' to value 'InstalledEulaVersion'
    [2594:0B24][2018-03-20T09:43:06]i000: Initializing string variable 'INSTALLING_EULA_VERSION' to value ''
    [2594:0B24][2018-03-20T09:43:06]i000: Initializing numeric variable 'APPLICATIONONLY' to value '0'
    [2594:0B24][2018-03-20T09:43:06]i000: Initializing numeric variable 'DRIVERONLY' to value '0'
    [2594:0B24][2018-03-20T09:43:06]i000: Initializing numeric variable 'NOSTART' to value '0'
    [2594:0B24][2018-03-20T09:43:06]i000: Initializing string variable 'ON_INSTALL_COMPLETE' to value '{CONFIG}'
    [2594:0B24][2018-03-20T09:43:06]i000: Initializing numeric variable 'FACTORY' to value '1'
    [2594:0B24][2018-03-20T09:43:06]i009: Command Line: '-burn.clean.room=C:\Users\lafru\Downloads\Tobii_Eye_Tracking_Core_v2.13.0.7241_x86.exe'
    [2594:0B24][2018-03-20T09:43:06]i000: Setting string variable 'WixBundleOriginalSource' to value 'C:\Users\lafru\Downloads\Tobii_Eye_Tracking_Core_v2.13.0.7241_x86.exe'
    [2594:0B24][2018-03-20T09:43:06]i000: Setting string variable 'WixBundleOriginalSourceFolder' to value 'C:\Users\lafru\Downloads\'
    [2594:0B24][2018-03-20T09:43:06]i000: Setting string variable 'WixBundleLog' to value 'C:\Users\lafru\AppData\Local\Temp\Tobii_Eye_Tracking_20180320094306.log'
    [2594:0B24][2018-03-20T09:43:06]i000: Setting string variable 'WixBundleName' to value 'Tobii Eye Tracking'
    [2594:0B24][2018-03-20T09:43:06]i000: Setting string variable 'WixBundleManufacturer' to value 'Tobii AB'
    [2594:0B24][2018-03-20T09:43:06]e000: Error 0x81f403e8: The Burn engine cannot run with an MBA under the .NET 4 CLR on Windows 7 RTM with .NET 4.5.2 (or greater) installed.
    [2594:0B24][2018-03-20T09:43:06]i000: Loading prerequisite bootstrapper application because managed host could not be loaded, error: 0x81f403e8.
    [2594:34D8][2018-03-20T09:43:06]i000: Setting numeric variable 'WixStdBALanguageId' to value 1031
    [2594:34D8][2018-03-20T09:43:06]i000: Setting version variable 'WixBundleFileVersion' to value ''

    The problem is windows framework. I use windows10, which got updated from win8.1.

    1) I tried to install a new version, but it claimed to be already installed
    2) I checked off and on the framework while restarting the PC in between
    3) I tried to check (that’s the funny part) both frameworks: The old one 3, including 2, and a second one. But when loading, windows told me, that it needs to restart to reset the settings

    Soooo…anyone have an idea how I get framework to work? Or at least recognize the eyetracker that it is there? I already tried the troubleshooter/repairtool by windows, but it didn’t find anything.

    Please, help. Otherwise I need to return the product…and where would be the fun in it.

    Grant [Tobii]

    Hi @patalou, thanks for your detailed report. After asking around, I am afraid that the error logs you shown is not a typical issue. A cursory search online showed that this error, “The Burn engine cannot run with an MBA under the .NET 4 CLR on Windows 7 RTM with .NET 4.5.2 (or greater) installed.” Seems to be related to Windows upgrades from previous version where .NET was not properly updated or installed.

    The common advice amongst the threads I found has been to uninstall and reinstall .NET runtime libraries or alternatively try installing the software in compatibility mode which it seems you already tried unsuccessfully. Did you try already reinstalling .NET?


    I’m afraid that’s the problem. I can’t reinstall .net framework. It tells me that it is already installed – I just can enable or deable it. That’s all. I looked around and found this (https://knowledge.autodesk.com/support/autocad/learn-explore/caas/sfdcarticles/sfdcarticles/How-to-remove-and-reinstall-the-Microsoft-NET-Framework.html), which doesn’t work, because of this

    “Note: Windows 8, 8.1, and 10 systems do not list “Microsoft .NET” as an installed program. Looking at “View installed updates” in Programs and Features in Windows 8 and 8.1 it may be possible to find the corresponding KB number and remove it that way. Windows 10 systems, however, with current updates from Microsoft, will not have any option to uninstall .NET. However, if your overall Windows Updates are not current, it may be possible to install the latest .NET version.”

    I really don`t know what to do…


    Working with Windows 10 is a pain due to windows updates failing from time to time. In my experience if your windows updates fail on a .net update then the only way to fix it is to do a Clean reinstall of Windows. I have tried every work around and most of the time they do not work. I had one case that i had to do 3 clean reinstalls because of windows problems. Like it was previously mentioned this is due to .net being built into windows and not being able to uninstall and reinstall separately.


    I HATE windows…and feel your pain. I always start to sweat, when the PC asks me not to shut down, because of updates. It always seems like Windows themselves have no idea what they are doing. I read somewhere else, that the problem might be, that framework IS installed, but they somehow changed the recognition number back and forth (as I said, I have no true idea about computer languages besides the most basic html) and now programs have trouble to recognize the tool.

    I hope I can fix it somehow else. It’s such a waste of time and nerves to setup a PC, especially if you moved and have no idea where the clean image is. Plus, I bet that there will be other problems waiting to be solved after the clean install. -_- And I just wanted to treat myself with a new gadget…

    I did something with cmd “sfc/scannow” and of course it found broken data. The log is rather large, so no way that I can post it here. I swear, I cry if I have to do a clean install and find Tobii is still not working. I truly will.

    Natalia Gonzalez

    Sorry guys but the solution to make a hardware workable on any OS is to have the right firmware or installation file, not reinstalling the OS. I´ll not do this just to check if Tobii will work or not! I´m not an IT person, I just want to use the device to help disabled people communicating and improving, that´s it. As end user I don´t need to know what a NET framework is, reinstalling OS, etc. It´s frustrating!
    Is it possible for Tobii to provide a new installation version suitable for Win 10 with bugs fixed instead of asking users for being experts on IT? I need your support please. Many thanks!

    Regarding the Alienware reco, I was not able to install Tobii even once! so non of the options on this link ( https://help.tobii.com/hc/en-us/articles/115004448085-Alienware-users-Is-the-eye-tracking-software-not-launching-)worked for me (I run the cmd but nothing was found as installation process never progressed from 50%)

    BTW, I´ve installed the software on Win10 Pro and worked, but my win10 home didn´t.

    Grant [Tobii]

    Hi @airmuze, sorry to hear the steps did not work for you. Unfortunately, whilst we do endeavour to ensure installation and setup of Tobii software is as simple as possible, there will still be occasions when a users computer has some unusual configuration or previous issues/bugs unrelated to the installer that causes issues.

    Fixing such issues does indeed necessitate a degree of IT knowledge much as with any other process when things go wrong. As you have discovered in installing on another laptop, things can work perfectly well if the computer’s system itself is well configured. And indeed the vast majority of our users are able to use our products, but as each computer system is different it is impossible to guarantee there will not be problems.

    What you may try is to reach out directly to Tobii Tech Support @ https://help.tobii.com/hc/en-us/requests/new who may be able to arrange a remote session with you and go perhaps diagnose the problem with installation.

    , it is rather strange your windows version is reported as Windows v6.1 (Build 7600: Service Pack 0) which if you are running Windows 10, should definitely not be the case. Yes installing Windows again is a major pain, but with so many issues arising from ‘upgrading’ rather than a clean install, this may unfortunately be your best bet to resolve the problem.


    Hi @Grant,

    we use the tobii software since many years an had never issues with the installation process. Except yesterday.
    On a completely clean new machine running Windows 10 with all updates. The tobii installation stops at 85% and then rollback everything.

    The installer log:

    [09FC:1AB8][2018-03-21T14:41:58]i001: Burn v3.10.2.2516, Windows v10.0 (Build 16299: Service Pack 0), path: C:\Users\meiro\AppData\Local\Temp\{8875B6CF-99FA-4313-A941-CA42FD6E7534}\.cr\Tobii_Eye_Tracking_Core_v2.13.0.7241_x86.exe

    319: Applied execute package: PACKAGE_Hello3Driver, result: 0x0, restart: None
    [21C8:12F4][2018-03-21T14:42:25]i325: Registering dependency: {62d9243b-66de-466a-99bd-2b01fc617ec7} on package provider: {EB7EEC55-D001-4EB4-AA84-35AC2D65FD3E}, package: PACKAGE_Hello3Driver
    [21C8:12F4][2018-03-21T14:42:25]i323: Registering package dependency provider: {7269D477-74B2-45A5-A9E8-06866E4DCF7E}, version: 1.5.604.0, package: PACKAGE_HIDComponent
    [21C8:12F4][2018-03-21T14:42:25]i301: Applying execute package: PACKAGE_HIDComponent, action: Install, path: C:\ProgramData\Package Cache\{7269D477-74B2-45A5-A9E8-06866E4DCF7E}v1.5.604.0\HIDComponent-Tobii-Generic.msi, arguments: ' ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7"'
    [09FC:1AB8][2018-03-21T14:42:25]e000: [CBA] Context error reported. Type=WindowsInstaller, Code=0, Package='PACKAGE_HIDComponent', Message='Microsoft Visual C++ 2015 Redistributable (x86) is missing. Please install it from Microsoft and retry the installation.'
    [21C8:12F4][2018-03-21T14:42:25]e000: Error 0x80070643: Failed to install MSI package.
    [21C8:12F4][2018-03-21T14:42:25]e000: Error 0x80070643: Failed to execute MSI package.
    [09FC:1AB8][2018-03-21T14:42:25]e000: Error 0x80070643: Failed to configure per-machine MSI package.
    [09FC:1AB8][2018-03-21T14:42:25]i319: Applied execute package: PACKAGE_HIDComponent, result: 0x80070643, restart: None
    [09FC:1AB8][2018-03-21T14:42:25]e000: Error 0x80070643: Failed to execute MSI package.
    [21C8:12F4][2018-03-21T14:42:25]i318: Skipped rollback of package: PACKAGE_HIDComponent, action: Uninstall, already: Absent
    [09FC:1AB8][2018-03-21T14:42:25]i319: Applied rollback package: PACKAGE_HIDComponent, result: 0x0, restart: None
    [21C8:12F4][2018-03-21T14:42:25]i329: Removed package dependency provider: {7269D477-74B2-45A5-A9E8-06866E4DCF7E}, package: PACKAGE_HIDComponent
    [21C8:12F4][2018-03-21T14:42:25]i326: Removed dependency: {62d9243b-66de-466a-99bd-2b01fc617ec7} on package provider: {EB7EEC55-D001-4EB4-AA84-35AC2D65FD3E}, package PACKAGE_Hello3Driver
    [21C8:12F4][2018-03-21T14:42:25]i301: Applying rollback package: PACKAGE_Hello3Driver, action: Uninstall, path: (null), arguments: ' ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7"'
    [09FC:1AB8][2018-03-21T14:42:28]i319: Applied rollback package: PACKAGE_Hello3Driver, result: 0x0, restart: None


    [09FC:1AB8][2018-03-21T14:42:36]i000: [CBA] Apply complete, status -2147023293
    [09FC:21D8][2018-03-21T14:42:36]i000: [CBA] Installing page receives BurnDoneMessage: Result=Error, Status=0, Restart=None, Message=Microsoft Visual C++ 2015 Redistributable (x86) is missing. Please install it from Microsoft and retry the installation.
    [09FC:21D8][2018-03-21T14:42:36]i000: [CBA] Page transition requested: INSTALLING -> InstallationError
    [09FC:21D8][2018-03-21T14:42:36]i000: [CBA] Transitioning to INSTALL ERROR

    This is strange because we have successfully installed the software hundreds of times. On Windows 7, 8 and 10, if the msvc2015 package would really be missing in the tobii installer, the error would have occurred very often in the past.

    We fixed the problem, the same way as we fix the “tracker can no longer be switched off”-bug: Just installing the version This version of the core software installes without complains.

    Grant [Tobii]

    Hi @chrisschaefer, thanks for the additional information…I shall pass your log data along to the developers. I wonder if the installer is incorrectly not finding MSVC2015, at least you have a workaround whilst we investigate the issue.

    I found this link @ https://stackoverflow.com/questions/12206314/detect-if-visual-c-redistributable-for-visual-studio-2012-is-installed to help you confirm it is indeed properly installed. I am sure it must be (to be able to install older versions of Tobii Core SW) but still would be useful to know the results.

    Natalia Gonzalez

    Do you have de 2.10 version to share so I can try if it works on my computer? thanks!

    Grant [Tobii]

    Hi @airmuze, I have PM you with a link to try on this older version… Please let us know here how it goes. Many thanks.

    Ryo Kanbayashi

    When I case, problem solved by stopping 「Windows Biometric Service」prior of Installation.

    Windows 10 Home edition 64bit

    Grant [Tobii]

    Hi @ryogrid, thanks for the tip! Hopefully of use to some of the other users facing this problem. I will report your finding to the developer team for further feedback if applicable.


    Hello, I recently purchased the Tobii Eye Tracker 4C. I downloaded the Tobii Eye Tracking Core Software v2.13.4, but when I try to install it I get the error “Some thing went wrong. We sorry, we couldn’t install”. I’ve read through this entire thread for solutions but I have found nothing that works. Any help would be appreciated, otherwise it’s getting returned.

    Grant [Tobii]

    Hi @kaseli sorry to hear about your issues. If you have already gone through the steps outlined in this thread which indeed covers a number of possible solutions, and still are no further forward, then kindly get in touch with Tobii Tech support directly @ https://help.tobii.com/hc/en-us/requests/new and they should be able to deal with your case individually. Hopefully you get up and running soon!

Viewing 15 posts - 16 through 30 (of 32 total)
  • You must be logged in to reply to this topic.