[Solved] Win7 USB 3.0 Initalizing Problem

Home Forums Software Development [Solved] Win7 USB 3.0 Initalizing Problem

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #1952

    First to say: I am NOT alone.

    I use a Lenovo Ideapad Z510 Win7 64 Bit

    I upgraded ALL drivers etc. recently.

    After installing and using one of two USB 3.0 Slots it says that it is trying to initialize but it gets stuck in an initializing loop?

    The other usb 3.0 Port does not even recognize Tobii.

    So…? Anyone knows how to solve it? 🙁

    Other USB 3.0 devices work without problems.

    Reinstall of setup etc. has been done!


    Hi there,
    have you had a look at our FAQ already?
    We have listed a few steps on how to handle USB 3.0 problems.

    I did google for the Lenovo Ideapad and USB 3.0 problems and found a threat (german): https://forums.lenovo.com/t5/IdeaPad-Notebooks/Problem-mit-USB-3-0-Schnittstellen-IdeaPad-Z510-Win7-64-Bit/ta-p/1459709

    However, there solution is to install the following driver: https://forums.lenovo.com/t5/IdeaPad-Notebooks/Problem-mit-USB-3-0-Schnittstellen-IdeaPad-Z510-Win7-64-Bit/ta-p/1459709

    Please try that and let me know if that worked out.

    If that doesn’t work, it would be great if you could provide some further information.
    Which USB controller is used in your laptop, you can see that in the device manager. Also what driver version is used (you can see that when double clicking the usb controller, then open the driver tab).

    About the other USB 3.0 devices.
    The usual problems with USB 3.0 (independent from Tobii EyeX) is that not all controllers/drivers are able to push the full speed of USB 3.0 or at least not constant. That means that the speed can go up and down. For a USB 3.0 memory stick this is not a problem as they are USB 2.0 compatible. So the only thing what will happen is that the speed is varying. However, for true USB 3.0 devices this ends up in a non working device, as they (as well as the Tobii EyeX) require 100 % USB 3.0 speed.




    Thanks for the information. I will try these on my laptop and I will give more information if I got the time to try it again on my laptop!


    I used the tracker differently on a Windows 7 and on a Windows 10.

    But tracker not detected with the Gaze SDK following the instructions in the dev guide.

    For the Windows 10 HP Laptop, EyeX worked before I uninstalled it.

    But for the other Windows 7 HP desktop, the tracker was not detected for the EyeX engine or the Gaze SDK via cmd.

    Both have USB 3.0

    Any thoughts?

    Grant [Tobii]

    Hi @stevo,

    without more information, it’s difficult to diagnose a generic connection problem.

    I would suggest you go through the FAQ and let us know if problems persist.

    Paweł Elert


    Many Thanks @Konstantin, your suggestion to use original intel (not Lenovo) drivers has solved my issues.

    Best regards

    Grant [Tobii]

    Hi @pawelelert, thanks so much for keeping us updated. Hopefully other users experiencing similar issue will find it helpful.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.