Home Forums Eye Tracking Devices et Windows 10 won't turn screen off and sleep

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #12211
    Ryan
    Participant

    Hi. I recently purchased a Tobii 4C and installed the core software. Since installing this I’ve noticed my computer would no longer go to sleep or even turn the screen off when it’s supposed to.

    Things I’ve done:

    1. Tripled check power plan timers
    2. Disabled Tobii Power Presence in power options
    3. Unchecked “Allow this device to wake computer” box for EyeChip under USB devices in Device Manager
    4. Turned off everything in the power settings of the Tobii software, however disabling power presence makes this section unavailable anyway, so they are disabled by default.
    5. Keep the eye tracker turned off via the software when not in use

    The only thing I didn’t try until now was closing out the Tobii software, and would you know my screen turned off after the set amount of time and the PC went to sleep.

    So is it possible to have the computer sleep with this software running or will I have to close it out each time I’m done using the computer?

    #12218
    Grant [Tobii]
    Keymaster

    Hi @ryanburnsred, sorry to hear about your issues and thanks for the detailed problem report. Can you confirm if something as simple as a Screen Saver works properly? If not, it would seem that something is sending a signal to the PC to prevent an inactive state.

    Does the issue persist if the Eye Tracker itself is connected or not? I assume that if you uninstall the Tobii Software, the problem is gone?
    Might also be an idea to ensure your Windows 10 is fully up to date and that any USB chipset drivers and BIOS are similarly updated.

    Unfortunately, this issue has not previously been reported, but hopefully, we can find a solution for you promptly.

    #12221
    Ryan
    Participant

    Thanks for getting back to me Grant.

    I set up a screen saver to activate after 1 minute. It would not activate while the Tobii software was running and the the eye tracker plugged in or plugged out.
    Closing the Tobii software allowed the screen saver to activate in both cases. Uninstalling the software and leaving the eye tracker plugged in would certainly allow the computer to idle.

    My Windows 10 is completely updated. In fact I updated it yesterday while trying to figure this out. All other drivers are updated for the hardware.
    I’ve even done an energy report through the CMD and it found nothing unusual that would prevent the computer from sleeping. In fact Tobii wasn’t mentioned at all, but the fact remains that it’s causing the problem. I really have no idea why this is happening

    Also the software starts automatically on boot and I cannot disable it through the task manager.

    #12229
    Grant [Tobii]
    Keymaster

    Hi @ryanburnsred, thanks for the extra information. This is indeed rather bizarre behaviour..

    We have created a bug report describing your issue that ideally we can identify what may be the source of the problem.

    In the meantime, I discovered a thread that may allow us dig deeper
    https://superuser.com/questions/387627/any-way-to-detect-what-is-disabling-the-screensaver

    If you could also reply with a detailed listing of your exact windows version, hardware installed, etc.. that would be great.. the more detail the better!

    Thanks for your patience, hopefully we can resolve this for you soon.

    #12243
    Ryan
    Participant

    Thanks for the link and creating a bug report. Hopefully you guys can replicate this. If there’s anything you need from me, I’d be happy to send it if I can.
    I did what was said in the link and made an energy trace report and looked at it in Event Viewer. I’ll be honest that it didn’t really make sense to me, but I did see one mention of the Tobii.EyeX.Tray.exe with a 110 event ID, however I don’t know if it means anything.

    Here is a screenshot of the about section in my Windows settings: https://imgur.com/a/U7yw3Bb
    If you’d also like to know currently plugged in hardware:

    USB:
    keyboard/mouse
    CH Pro Pedals
    Saitek X52
    CSR 4.0 bluetooth adapter

    Typical software I heave running in the background are:
    Corsair Link
    MSI Afterburner/RivaTuner
    Steam
    Tobii Eye tracking software

    If there’s anything I’ve left out please let me know

    #12247
    Grant [Tobii]
    Keymaster

    Thanks for that extra info @ryanburnsred. Out of curiosity, can you try disabling the Corsair Utility? We had a couple of issues with this SW in the past.. it may be unconnected but worth a shot.

    #12251
    Ryan
    Participant

    I closed it out and left everything open and waited for the screen saver to show up but it never did. So same result as before.
    Don’t know if you guys need this, but here’s the About section of the Tobii software https://i.imgur.com/kFnuxo9.png

    Says eye tracking disabled at the bottom because I keep the tracker turned off when I’m not using it.

    One thing I didn’t mention before was that I previously had an EyeX tracker. The older one that required USB 3.0 and without the head tracking. I don’t think I had this issue with that. I stopped using the EyeX for awhile and uninstalled the software back in July this year. Then I recently got the 4C in October and reinstalled the software. My old profile was still there so I just recalibrated it. Do you think it’s the EyeX taking it’s revenge on me for upgrading?

    Is there a way for me to completely remove everything Tobii and start over?

    #12260
    Grant [Tobii]
    Keymaster

    Cheers @ryanburnsred, we are continuing to investigate the issue .. if you could let me know which computer hardware you are running (is it custom built box?) or computer model? thanks a lot. By the way, I assume that if you disable the Tobii Serivces (Start -> Run -> services.msc -> Tobii Service) then you can sleep the PC?

    It’s not a very elegant solution, but you could make a little batch file ‘Net Stop “Tobii Service” ‘ which you could execute before sleep as a workaround until we figure a proper fix.

    #12268
    Ryan
    Participant

    Glad to help in any way I can. I’m running a custom built PC.

    As for the Tobii service: I did disable it at one point seeing as it was the only way to stop the eye tracking software from starting on boot. I set it to manual activation then restarted the PC. The Tobii software didn’t start on boot, and so the PC went to sleep after the set time.

    However I would have to re-enable the service manually in order to use the eye tracker because without the service running I can’t enable the 4C.

    The batch file is a great idea, but ultimately it’s no different than just closing out the software from the tray when I’d like the computer to sleep.

    #12433
    nathan dev
    Participant

    I got the same issue using the Tobii service, it will start turning the monitor off, but it will turn itself back on automatically almost immediately. Something is interfering but I cannot figure out what. No security software installed (using Defender, tried disabling it). The only way this works as intended is in Safe Mode.

    #12444
    Grant [Tobii]
    Keymaster

    Hi @ryanburnsred @nathandev just to let you know we are actively working on the fix for this and will implement into a forthcoming release soon, so please check back for updates regularly @ https://help.tobii.com/hc/en-us/categories/360000281034-Tobii-Core-software

    Thanks for your patience whilst we ensure this bug is properly squished 🙂

    #12448
    Ryan
    Participant

    Hi. I recently upgraded my PC. I changed the motherboard and CPU from the Asus Rampage 3 Formula + Xeon X5675 to the MSI X299 Raider + i7 7820X.
    Here’s where it gets interesting…

    Previously the PC would not sleep or turn the screen off with the Tobii service running. It seemed evident that was the culprit on my old setup.
    However now I can keep the service running and the PC would sleep normally. The culprit this time are the CH Pro Pedals I had plugged in.

    I searched Google for this and found a Reddit thread mentioning this problem with these pedals specifically and 2 other threads on different forums about game controllers in general preventing Windows 10 from entering sleep mode

    Looking at the input of the pedals from the W10 game controllers menu and I can see it is constantly inputting phantom movements in the X axis, possibly preventing the computer from sleeping. Solution it seems is to keep it unplugged or get a powered USB HUB with power switches.

    It’s very odd. On my old board the problem was Tobii. On my new board the problem are the CH pedals. I don’t understand computers.
    Either way my problem is solved as far as Tobii is concerned. Thank you Grant for all the follow ups you’ve done. Nathan I have no idea what could possible be the issue in this and hope the Tobii devs can figure it out

    #12450
    Grant [Tobii]
    Keymaster

    Hi @ryanburnsred, thanks for your follow up and reporting the changes.. most bizarre! Glad to hear that at least you managed to find some kind of resolution, although not ideal of course and you still have to unplug a device to sleep the computer.

    Other users have reported issue with Tobii preventing sleep, but good to know it may be motherboard specific and useful for investigating further. Happy Gaming! 🙂

    #14034
    Alan
    Participant

    Hi there, new 4C user here.

    My Windows 10 cannot turn the display off properly using the latest Tobii Eye Tracking Core Software v2.16.5 with no GameHub installed.

    How to reproduce:
    – Windows 10 Hello Face is disabled.
    – under Power Options, change power button action to “Turn off display”
    – Press the power button, the screen goes off for a second but is immediately back on.
    – Quit the Tobii Eye Tracking application by right clicking the taskbar icon -> Quit.
    – Press the power button again, the screen now goes off without coming back on.

    Disconnecting the 4C from USB physically while running the Tobii application or using the Tobii’s “on/off” switch won’t make any difference.

    Any idea? Thanks!

    #14272
    Daniel Fischer
    Participant

    Hi,

    i can confirm this too. Its really annoying. I tried everything to get my built-in windows 10 screensaver to lock my screen and my computer to turn off the screen after 10 minutes (which worked since years before i installed the tobii software).

    I have 2.16.5 installed as well

    My windows = Windows 10 Pro 64-Bit (10.0 Build 18363)

    Its definately a problem with the tobii software and has no relation to other drivers or products.

    Please bring an update asap as my screens are not locked which is absolutely inacceptable in my situation (use it for work too) and i am used to have it lock automatically after one minute.

    Also its not good for my displays/monitors that they do not turn off during the whole night. Also it costs power and is not enviromenent friendly and costs me money as well.

    Please fix asap.

    Thanks
    Stonegate

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.