Home Forums Eye Tracking Devices EyeX works once


Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #6253
    Sidney Araujo Melo

    Hi, I’m not sure if this is the right place but I had this strange error twice. First time I installed the Tobii Eye Tracking Core, the EyeX worked fine. I tested some games and it worked perfectly. The following day, the EyeX wouldn’t even connect; two lights blinked and that’s it, no response at all (the tracking app was gray). I reinstalled it and it worked again. The following day, after restarting the computer, the device wouldn’t work again. So, right now I need to reinstall it every time I need to use it. Any help?

    Thanks in advance!

    Grant [Tobii]

    Hi @sidneymelo, The first thing I would suggest is to check for any running Antivirus or Firewall software on your system that may be running on your system and interfering with the connection. Also, could you kindly include the hardware specifications for your computer system? Do you have a secondary computer to test against our of curiosity?


    Sorry to hi-jack but I am having the same exact issue. After upgrading to V2.11 Tobii EyeX has stopped working after Windows Restart. “No eyetracker connected”. Nothing has changed except for installing the new Core installation.

    The only way for me to use it, is to uninstall and reinstall every time I want to use my Tobii Eye.

    Using Tobii.EyeX_2.1.1.293 also works. Something is obviously wrong with the new V2.11

    It would be great if I can at least find out the latest working version before V2.11 as my only option is V2.1.1 as this is working flawlessly.


    In addition the download section is extremely frustrating as I cannot find any of the previous versions. The only thing I can update is tobii eyex engine 1.9.5 and this has to be done via the v2.1 “check for updates” option.


    I have managed to find out a drivers repository and it has the following tobii versions:
    Tobii_Eye_Tracking_Core_v2.5.0.5588_x86 (WORKING)
    Tobii_Eye_Tracking_Core_v2.6.1.5748_x86 (SKIPPED)
    Tobii_Eye_Tracking_Core_v2.7.0.5807_x86 (SKIPPED)
    Tobii_Eye_Tracking_Core_v2.8.0.6094_x86 (SKIPPED)
    Tobii_Eye_Tracking_Core_v2.9.0.6265_x86 (SKIPPED)
    Tobii_Eye_Tracking_Core_v2.10.0.6432_x86 (WORKING)
    Tobii_Eye_Tracking_Core_v2.11.0.6827_x86 (NOT WORKING)

    I am going to go through the different versions and see which ones work as obviously v2.11 is messed up. It might work with the brand new Tobii but seems to have no love for the older EyeX models:(


    Tobii_Eye_Tracking_Core_v2.10.20.6674_x86 (WORKING)

    I would suggest only using version with Tobii EyeX as it is the latest version working. For whatever reason version is NOT WORKING with the older EyeX.

    In addition if you want to have your Tobii OFF make sure to set the Tobii EyeX Interaction to OFF then in Windows Services the Tobii Services to MANUAL and use the following CMD short-cuts when you want it enabled and disabled:
    C:\Windows\System32\cmd.exe /c ” net start “Tobii Service””
    C:\Windows\System32\cmd.exe /c “net stop “Tobii Service””

    Grant [Tobii]

    Hi @drei69, thank you very much for the detailed report and brining this to our attention.

    I shall forward your experiences to our development team who should hopefully be able to fix this problem for a forthcoming release, our apologies for any inconveniences during this time.

    Anders Faust

    Ok! got exactly the same issue!

    I opened a suport ticket and we first managed to find a solution (moving the display port cable on the second port, with full clean-up (registry/files/folders) and complete re-installation, but … then it failed again!

    I’ll try downloading 2.10 then and let you know too!

    (Official download link in case you need it)

    Will let you know if 2.10 works better

    Copy of my support ticket for information 😉

    Okay so here is the issue!

    I first installed successfully the Eye Tracker frm my Acer Z271T screen, and calibrated everything, installed Also some games using it (Assassin’s Creed Syndicate, Tomb Raider) Tracking was working awfully.

    Then I wanted to perfect the calibration of my Profile, so I started to calibrate it again, but here I closed the calibration before it was fully done, and from here I was completely unable to have the Eye Tracker working again!

    Well in fact, the Eye Tracker is connecting, starting, but I’m am completely unable to create a new calibration profile, the program simply doesn’t start at Alll!

    What I did:
    – Completely removed all drivers, software, then reboot, and reinstalled everything, eye tracker is detected, ok, but still unable to configure a new calibration profile

    – I then completely removed all drivers again, but this time I searched for every files related to Tobii to clear the to (Files AND Windows registry keys) I though this could also clean up “bad and/or corrupted” profiles configurations, to start a fresh one, then re-installed again, with no success!

    – I also tried the USB 2.0 trick, but still no luck (my USB controller is an ASMedia 3.1 Hub on motherboard) still no success!

    – Well I’m SURE my Eye Tracker is “working” because I can configure Windows Hello, see the camera filming my face, and Windows Hello do recognize me! but I can’t create/calibrate a trackinbg profile at all!

    – I also tried running tobii configuration from shell.

    When running this command:
    C:\Program Files (x86)\Tobii\Tobii EyeX Config\Tobii.EyeX.Configuration.exe -H
    the Eye Tracker program is starting, and Eye Tracker lights up, I see my eyes, then it’s simply closing, all other options (Configure, Guest, etc … doesn’t work at all)

    So here I am, I also joined the debug archive to this support request, hope you can help me.

    Thanks for your time!
    Looking forward for your reply!

    Thank you for contacting us and sorry to hear about your issue. You could try to remove power cable of the monitor and then replug cable to reset it entirely.

    Eye Tracker needs correct information of screen to work properly, you could try to reinstall graphics card and screen driver as well. Replugging HDMI/DP cable sometimes does the trick. you could try it as well.

    It seems you have tried to delete tobii registries and folders. here are all of its location. maybe you can check if anything you missed.



    Please keep me updated, thanks.

    Best Regards,
    Tobii Tech

    Me again

    Okay well, It’s working again now!

    What I did exactly

    Removed all Registry Keys & File & Folders
    Uninstalled EyeChip usb, unplugged USB Cable
    Un-plugged Monitor Power while restarting windows

    Then I Re-installed Tobii software, and … it didn’t worked!

    So Last chance, As you said “Replugging HDMI/DP cable sometimes does the trick”
    I simply moved the DisplayPort cable on the second GPU DP Port, and Miracle, configuration started again!

    Absolutely tricky! but It’s clearly an issue during the Monitor identification or something like, Hope this also helps you troubleshoot more issues like this and Maybe find a patch for the next updates 🙂

    Thank you!

    Grant [Tobii]

    Hi @andersfaust, can you kindly confirm that downgrading to an earlier version of Tobii Eye Tracking Core SW resolved the issue? We are trying to link related problems through this solution. Many thanks.

    Anders Faust

    Hi @grant-rogers, yet I downgraded to version Predator_Eye_Tracking_Core_v2.10.20.6674_x86.exe and EyeTracker is working now

    I have another issue (but I don’t think it’s related to the driver)

    But for information

    Every time I restart my computer my monitor (Acer Z271T) is detected as “Plug-n-Play Monitor” in my system devices list, and is “not activated” I have to manually activate it for the Eye Tracker to “detect it” and work

    However, the Eye Tracker doesn’t loose any configuration and apart the monitor issue, is working flawlessly.

    Grant [Tobii]

    Hi @andersfaust, okay thanks for the update. As for the monitor issue, you correctly pointed out this seems unrelated to the Tobii Tracker.

    I assumed you already tried removing the ‘plug and play monitor’ from device manager and restarting to see if that works? And perhaps try to ‘update driver’ and point manually to the latest monitor drivers?

    Grant [Tobii]

    Hi @andersfaust, may I ask how are you progressing on the plug and play monitor issue? I assumed you trying update/reinstalling the NVIDIA drivers? Related problems are somewhat common regarding Windows not finding the proper monitor driver.

    Apologies for the inconveniece regarding the installation of older software, we are working on fixing the issue as soon as possible for a future release of the Tobii Eye Tracking Control Software.


    I was provided the same steps, to delete all traces of the previous software and drivers, however since downgrading and using V2.10 worked, I really did not have the patience to waste any more time on this issue:)

    Already did most of those steps during my troubleshooting, took me around 3 hours to sort it out. Most of the time was waste trying to get previous versions of the software.

    Just in case this wasn’t clear. Version 2.11 does work, however it only does so when you first install it. The moment you shutdown and restart your PC, that’s it, it no longer works. Only fix is to uninstall and reinstall, and it will work again until you restart your machine.

    Grant [Tobii]

    Hi @drei69, sincere apologies for the inconvenience caused by this issue. We are actively working on resolving this problem for a forthcoming release of the Tobii Eye Tracking Core Software. Thank you for your patience.

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.