Home Forums Eye Tracking Devices Cannot connect to eyetracker

Viewing 15 posts - 1 through 15 (of 59 total)
  • Author
  • #1048
    Damian Lohmann


    i have a big problem with my EYEX. Its not running.
    Nothing harder than having the EYEX in front of you, looking at you and not been working. ๐Ÿ˜‰

    Computer:TERRA PC-Mini 6000 SILENT GREENLINE(http://bit.ly/1lOEBle)
    System: Windows 7, 64-bit
    USB 3.0: ASMedia XHCI Controller, Version:, Date: 07.03.2014

    1. When i boot the computer the EYEX blinks one time red for 0,5 seconds and is black again (yes,it’s in the blue USB 3.0 slot ๐Ÿ˜‰
    2. In Windows the Tobii SDK shows “Searching for eye tracker” and after a while “Cannot connect to eyetracker”
    3. I did several reboots and tried many driver-version. Without success!
    4. Is there any newer ASMedia Driver?

    Please help me out!

    Regards and many thanks


    Hi Damian,
    I saw your email and replied to you earlier today.

    Newer Asmedia drivers are available here: http://www.station-drivers.com/index.php/component/search/?searchword=asmedia&searchphrase=all&Itemid=5


    Damian Lohmann

    Hi Konstantin,

    thx for your immediate reply!

    I updated the driver to the newer “Asmedia ASM-104x/107x Drivers Version” (Link

    After installation I rebooted my systema and reconnected the EyeX.
    The tobii-window popped up, showing “Updating EyeX controller firmware” and closed itsself after ~1 minute. When I open the tobii software it’s still the “could not connect to eyetracker”

    Any idea, what i shall do next? I mean the EYEX is alive – let’s get her start talking ๐Ÿ˜‰

    Regard Damian

    Brooks Brown

    I too am having this issue. I plug it in the the USB 3.0 port (confirmed working with other devices), it says thanks and starts trying to update the firmware. After a minute it stops, and nothing happens. No connection, no lights, not able to find anything.

    Most unsettling is the fact that the Tobii Eye X isn’t in the device manager, but the Bootloader is. Should I assume that the firmware failed and my eyex is bricked?

    Brooks Brown

    Okay – I believe it is fixed now, and I got beyond the eternal firmware updates.

    Open device manager, and look for libusb (winusb). That’s the place tobii is at. Under that heading, Tobii Bootloader might be showing. It was for me. Right click, and uninstall it, choosing to delete the driver from the system.

    Then unplug the EyeX, and wait. When it’s done, plug the eyex back in. If it shows something else under that heading, you’ve done well.

    Then go into the folder itself where all your Tobii stuff is. Go here by default:

    C:\Program Files (x86)\Tobii\IS3 Driver

    And install that driver. AFter that, everything kicked back into high gear, lights flashed, and calibration started after a few minutes.


    Hi Damian,

    when going through the thread as well as this one here: http://developer.tobii.com/community/forums/topic/moved-could-not-connect-to-eye-tracker/
    The ASmedia doesn’t seem to be the most reliable USB 3.0 controller. On the internet there are several reports about problems also with other USB 3.0 devices.
    I haven’t seen any Asmedia working with the EyeX, yet.
    We have ordered some motherboards with Asmedia controllers and will have a more detailed look at it, but this may take some time.

    Any chance you can acquire one of the tested ones?
    http://developer.tobii.com/support/ (check My Computer doesnโ€™t have any native USB 3.0 port, how can I use the Tobii EyeX Controller?)


    Damian Lohmann

    Hi both!

    @Brooks: Thanks a lot four your advises, but nothing works out. Tried all your steps but the Software still “cannot connect to eyetracker”

    Any other ideas?

    @Kontantin: Thx for your great work! Nice to see that you are handling these ASMedia problems! Im’ looking really forward to updates on the ASMedia driver! Take your time!
    Unfortunately i can’t try one of the acquired USB-Controllers – at work i have a Terra silent mini computer (LINK) – no chance to install any other controller ๐Ÿ™

    Regards Damian

    Damian Lohmann

    Hello again,

    : Do you have any new informations regarding the Asmedia USB Drivers? Could your technical guys solve the problems?

    Thanks a lot!

    Regards Damian

    Jenny [Tobii]

    Hi Damian,

    There is still no solution to the ASMedia problem. We have been in contact with ASMedia and are trying to get a solution in place. The problem seem to be caused by an imcompatability in how the ASMedia drivers respond to a query API call from libusb. This means we are dependent on the solution being implemented either by ASMedia or in the libusb library. We are pushing for a solution, but don’t know when one could be in place.

    Damian Lohmann

    Hi Jenny,

    thanky for your immediate response!
    It’s impressing how your team answers all those questions so fast!

    I’m really looking forward for a solution. Keep us informed ๐Ÿ˜‰

    Regards from Germany


    Hi, I ran into the same ASMedia issue and found that it is probably the one discussed here:


    There is also a possible workaround mentioned there. The workaround fixes the issue for me, so for others to try I uploaded a libusb with this workaround to github. If you like to try it, you can download the DLL from here:


    Just replace the dll in your Tobii\Tobii EyeX Controller\ directory with this dll. You may have to restart Tobii or your computer.


    Damian Lohmann

    Hi Enrico,

    thanks a lot for your post.
    I tried the dll but nothing works out. ๐Ÿ™
    I replaced the dll in your restarted several times, but nothing works.

    Any new ideas?

    Kind regards Damian

    Mattias [Tobii]

    Hi Enrico and everyone else checking out this thread,

    Thanks for all the feedback, and in particular the tips and ideas for solving the driver problems that some people are having. It really is most helpful with that sort of help from the community, and from our side we follow up all leads. So thanks yet again.

    I also wanted to take the chance to give a heads up that we rather soon will roll out a new eye tracker firmware release that will improve both stability and communication as well as improving the eyetracker data quality.


    Max Malloni


    here the same problem. After installing the Tobii ExeX 0.10 it tries to initialize without any success.
    I tried many times to install & uninstall but no way: it does not work (no red lights at all, just at the beginning).

    Tobii USB Service version:
    Tobii EyeX Controller 1.0
    Tobii EyeX Version

    USB Silverstone SSt-EC04-P USB 3.0

    Thank you for your help,


    Roland [Tobii]

    Hi Max,
    could you post the contents of c:\programdata\tetserver\servicelog.txt?

Viewing 15 posts - 1 through 15 (of 59 total)
  • You must be logged in to reply to this topic.