Home Forums Eye Tracking Devices Cannot connect to eyetracker

Viewing 15 posts - 31 through 45 (of 59 total)
  • Author
  • #1686


    My tobii eyeX controller was working fine till yesterday. But today when plugged in the tracker at frist it was not detected. Then the firmware got updated from Tobii.Eye.Experience_0.8.17.1196-alpha to Tobii.EyeX_0.10.0.1889-alpha… After the reboot the device was detected and i was prompted to calibrate. When I start the calibration the tracker detects my eyes then starts the calibration process of following the white dot; once the process is complete I get the follwoing failure message every time and then the device turns off the red lights. I am not able to get past this step.

    error msg is as follows:

    Detection Failed

    Some tips:
    – If you are wear glasses, make sure that they are clean
    – Avoid direct sunlight
    – its ok to blink

    I have the environemnt that i had when everything was working; so I dont have a reason to doubt my environment.

    I tried to revert back to the old driver Tobii.Eye.Experience_0.8.17.1196-alpha but then the eye tracker simply wont get detected at all. Has any one else faced this problem? Please help me out.

    Mythreya MS

    Mattias [Tobii]

    Hi Mythreya,

    We are looking into this. Could you please help us and check something? Check that your screenplane still seems to be set up all right. You can do this from the settings panel. Firstly check that it identifies the screen correctly, and secondly that the two indented (barely visible) marks on the EyeX controller coinsides with the “scale-marks” drawn on the screen (i.e they should not be coincide with the full length of the Eye-tracker as with the REX). Errors with the screen plane can give errors of the kind you experience but it should not happen due to an upgrade, but it is nevertheless worthwhile to try while we are looking into other sources of error.

    Please post here if this solves something for you.


    Damian Lohmann

    Really strange… it has worked till yesterday and now it is out of order again: “No eye tracker connected” – Don’t know what happened.

    Tried to plug out/in the usb cable, but the only thing it does is one short blink.

    Any ideas guys?

    Here is my servicelog:
    UT] Could not obtain parental information at 2014-9-19 12:55:41
    [UT] Could not get information for root hub. Assuming USB3 at 2014-9-19 12:55:41
    [UT] upgrading EyeX Controller… at 2014-9-19 12:55:41
    [UT] Device has latest fw. at 2014-9-19 12:55:42
    [CT] status updated to: 0 at 2014-9-19 12:55:42
    [CT] status updated to: 0 at 2014-9-19 12:55:42
    [WD] create thread ok at 2014-9-19 12:55:42
    [WD] thread started at 2014-9-19 12:55:42
    [UT] thread exited at 2014-9-19 12:55:42
    [WD] EyeX Core started at 2014-9-19 12:55:42
    [WD] EyeX Core exited. at 2014-9-19 15:24:7
    [WD] stopping thread at 2014-9-19 15:24:7
    [WD] Terminating thread. at 2014-9-19 15:24:9
    [WD] EyeX Core already terminated at 2014-9-19 15:24:11
    [WD] Thread exiting now. at 2014-9-19 15:24:11
    [WD] stopping thread ok at 2014-9-19 15:24:11
    [CT] thread created at 2014-9-23 9:3:44
    EyeX Controller is not connected at 2014-9-23 9:3:44
    [CT] thread created at 2014-9-24 9:10:58
    EyeX Controller is not connected at 2014-9-24 9:10:58
    [CT] thread created at 2014-9-24 9:38:55
    EyeX Controller is not connected at 2014-9-24 9:38:55

    Kind regards


    Thank you Mattias

    I have tried that. But still the problem persists.

    Mattias [Tobii]

    Hi Mythreya,

    Ok, thanks for helping us eliminate that errorsource. We have a few leads that we are following up and will post here as soon as we have something for you.

    Michael Mellquist

    I too have this problem. I got it working a few seconds after having connected to the USB 2.0 port and then changing back to usb 3.0 when the “Your eyes” demo started… :S

    Michael Mellquist

    I have now tried 2 different EyeX devices, same result. When I manage to get the demo started, and start making a profile, the device disconnects when I’m supposed to follow the yellow dot.

    Martin Kopecek

    Hi Folks,
    I have same problem as Max Malloni,

    After the newest firmware )(Tobii EyeX 0.10.0 (device drivers, EyeX Engine and EyeX Interaction software):

    When i boot the computer the EYEX blinks one time red for 0,5 seconds and is black again (yes,it’s in the blue USB 3.0 slot 😉
    In Windows the Tobii SDK shows “Searching for eye tracker” and after a while “Cannot connect to eyetracker”
    I did several reboots and tried many driver-version. Without success!

    I think there is some USB driver (Intel) problem too, please Help me.

    USB 3.0 :

    Intel(R) Corporation
    Firm. version:
    Microsoft Windows Hardware Compatibility Publisher
    Hardware ID:

    maybe important this:
    Intel(R) 8 Series USB Enhanced Host Controller #1 – 9C26
    Fim version:

    Thank you, Martin

    Mattias [Tobii]

    Hi Michael,

    What FW version do you have on the EyeX Controller?


    Martin Kopecek

    Hi Folks,
    any idea what is wrong with my firmware?

    Thanx Martin

    Sean Doyle

    Hi –

    I’ve just had a similar set of issues with the Renesas USB – after uninstalling/reinstalling several times it turned out to be the USB cable.



    I’d encourage everyone who has connection problems in any way, to really make sure, to go through our FAQ: http://developer.tobii.com/support/

    Connection problems are usually due to non updated USB 3.0 controller driver, which in this case are not related to the Tobii EyeX. So start having a look at the FAQ, especially read the article “Manually update the USB 3.0 controller driver”.
    If those articles are no help at all, contact our Support department.




    I just got my Tobii EyeX device and have two test laptops…it worked straight away on one and wont on the other.

    It’s not being recognised on my Dell E7440 but got picked up immediately by my Vaio svf15aa1qm…both are i5 8GB laptops running Windows 8.1.

    The only real difference I can see in the device driver settings is that if you check the “Universal Serial Bus controllers” node in Device Manager, my Dell is running an Intel(R) 8 Series/ chipset USB Enhanced Host Controller, while the Sony Vaio is running an Intel(R) 7 Series/C216 chipset USB Enhanced Host Controller.

    I only got my Tobii device today so have not done too much tweaks on device driver versions but my drivers are pretty much up to date (Aug 2014) but will keep digging around.


    Hi there,
    could you please check what driver versions the USB controllers are using?
    You can see that in the device manager, double click then details.
    Also, check the driver version for the HUB, in case of the Intel(R) 8 Series… it’s called USB Root Hub (xHCI).



    Mattias [Tobii]

    Hi Kenricm, Martin and Michael,

    Today we released EyeX engine 1.1.0


    The EyeX Engine 1.1.0, amongst others, includes improved logging information, and with this you could help us to understand and solve the problem you face better.

    Please access the “diagnostics tool” under the “About” tag in the EyeX settings panel. The tool will create a zip file with logging and system info that you can provide in communication with our support team.


    Looking forward to get to the core of your problem.


Viewing 15 posts - 31 through 45 (of 59 total)
  • You must be logged in to reply to this topic.