Home Forums Eye Tracking Devices Eye Detection Indicator stuck in Initializing

Viewing 15 posts - 16 through 30 (of 41 total)
  • Author
  • #2743

    The commands mentioned above were more a individual solution and are not gonna solve all “initializing..” problems.
    However, in your cases, the name of the file which in your case is now “…1.3.1-31329.img..” changes depending on the firmware, so you manually need to look in the folder what the file is called.

    Anyways, most of the times, the “initializing..” error appears if the USB 3.0 controller driver is not up to date, so that would be my first advice for you to look at.
    More information is available in our FAQ: http://developer.tobii.com/support/
    Or otherwise there’s also been a longer thread here: http://developer.tobii.com/community/forums/topic/cannot-connect-to-eyetracker/


    Larry Molocznik

    Turn off your Anti-Virus software and try re-installing.
    That worked for me.

    Carl Thomé

    Same problem with the EyeX controller here. It used to work, but stopped working recently. Possibly broke with an EyeX engine update?

    Carl Thomé

    This didn’t help much:

    upg.exe fw_dl_util.exe h5flasher.img p2b-is3fw_1.3.1-31329.img
    The firmware on the device is either same or newer then the one used for firmware update.
    Igor Oliveira

    I’m Having the same problem. My Tobii used to work, but recently it stoped, and gets stuck in initializing.

    I updated everything, USB 3.0 ports, I tested in every port.

    I did the instructions in cmd and now I’m getting the same as Carl Thomé:

    “The firmware on the device is either same or newer then the one used for firmware update.”

    Anyone know how can I solve the problem?


    Sebastian Halder

    I also have this problem. The outer LEDs blink nothing else happens. The software says initializing. The command line instructions show the same message as in Igor’s post.

    Nathaniel Bahta

    Mine worked fine for about a week, no issues. Now its just stuck on initializing. Not sure what to do here. Any ideas?

    Jenny [Tobii]

    Hi Nathaniel,

    We are aware of this problem and we are trying to figure out root causes and solve them as we find them. The eye tracker getting stuck in initializing can be caused by a number or underlying issues, so even though we have hunted down and solved some, there are still some even harder to track down issues we haven’t found the root cause for yet. But we are working on it…

    The only suggestion I can give you at this point is to try and restart the computer and see if it helps.


    I’ve got it yesterday and could not test any second in a game, also always depends when initializing, it’srecognized by Windows 10 and appears in Device Manager

    best regards

    Rob Giordano

    Mine is stuck too, shut off McAffee, reloaded drivers, still nothing. When I checked EyeX in device manager it says drivers are not loaded!

    Marc Pleijsier

    I fixed this issue very easy. I used USBDeview. It’s a freeware piece of software. Install it than open it and the tobiieyeX device. Right click the device and disable it. than right click again and enable it.
    After doing that the lights came back on and the device was ready to use.


    Ian Storring

    Using Device Manager and disabling and then enabling my SteelSeries Sentry (Tobii EyeX) would get me passed Initializing. Though, when I try to Calibrate… I get a Windows noise like I unplugged the Eye Tracker, and it disappears from Device Manager and all lights shutoff and I can’t follow the dot. Now, if I disable and then enable the ASMedia USB 3.0 XHC that the Eye Tracker is plugged into, it shows back up in Device Manager… but I can’t continue to Calibrate. Seems like a common issue, from what I’ve been reading.


    I had this issue as well. It had been working for several days until I unplugged the device to re-route the USB cable and plugged it back in. Computer restarts and enabling/disabling the USB device did not work. After a restart it would be stuck on “Initializing”. If I disconnected and reconnected the device I would get the message “Eye Tracker Connected” over and over again from the Tobii EyeX Engine tray application and it would not longer load.

    Originally I got everything setup using https://steelseries.com/sentry/start, which is the link that comes with the instructions for the device. It may look like the better link to use is http://developer.tobii.com/eyex-setup/

    I tried disconnecting the device, closing the Tobii EyeX Engine, and uninstalling everything in Programs and Features that started with “Steelseries” or “Tobii”. Then I re-installed using the http://developer.tobii.com/eyex-setup/ link which appears to install much more updated software which also updates the firmware on the Eye Tracker. All good again so far!

    It may be that just a simple re-install of everything would’ve worked, but new link has newer software.

    Grant [Tobii]

    hi Tyler (@tnblank77), thanks for the update.

    Hopefully re-installing the Tobii software with the latest version will fix this issue for most users.

    Mario Klingemann

    Thanks for the update indeed! After uninstalling everything and reinstalling the new drivers and tools it finally works for me, too.

    I still have a major problem though, but that does not seem to be specifically Tobii-related but rather a Windows 8.1 / graphics driver issue, since it happens sometimes with other apps, too: whenever I have a second screen attached to my notebook the Tobii app will crash. So in case anyone has similar problems I recommend to try running/installing Tobii without a second screen attached.

Viewing 15 posts - 16 through 30 (of 41 total)
  • You must be logged in to reply to this topic.