Home Forums Game Integration sporadic problem: 4c device not found after reboot

Viewing 15 posts - 1 through 15 (of 47 total)
  • Author
  • #6133
    Michael Lehner

    Sometimes i have the problem that after restarting the computer, the 4c device is not being found by the software. This is a thing between the Tobii EyeX software, of which i use version 2.5.0, and the device. The ISE is not involved.

    The software just keeps the “serach circle animation”, without ever displaying the tracked eyes. When opening the window, it displays that no device is found. As i had the effect again today, i have created a new diagnostics pack and am ready to supply it.

    Some additional info to this case, though:
    – My computer starts from SSD, and does so faster than normal.
    – I previously also ran into issues with initialisation with my soundblaster card. I had to find out that the driver took too long to initialize for the speed of my system. (There is a number of people on the soundblaster forum who report the same problem. Unfortunately soundblaster is either unable or unwilling to fix the issue. )
    – After disabling a number of switches in Windows 10 which makes it boot faster, the issues with the soundblaster are resolved.
    – Now despite my system already being set to “boot slowly”, the 4c sometimes runs into issues which at least for me look a runtime problem at startup.

    Mind you, i am well aware that the soundblaster driver might well be the actual culprit, using much more time than other drivers at startup, so your driver just doesn’t get ready on time. Still i wonder if there is a way you could prevent this “self-lockout”.

    Mind you, i consider it to be of low priority, it happens sporadically, it occurs right after booting the computer (so you don’t have many other things going on which you don’t want to stop), it’s very obvious when it happens and it can be fixed by a simple reboot. But i still think you should know, so you can take a look into it at some time. 🙂

    Just please let me know what info to add to the e-mail where i send my diagnostic-pack file, i don’t really want to add that to a public forum. 🙂


    I have the same issue, I noted that the device works if you go into windows services and manually restart the service.

    I suspect there may be some conflict with another service or driver on my system that is causing this… you will note that the tobii service is literally one of the first services that loads up on the computer.

    I tried changing the automatic setting on the service to “delayed start’ that has worked… it just takes way too long to start that service with a delay,

    I’m working on a batch file now to add to the system startup that will start the service after a minute and then open the ISE software after the service is running.

    Michael Lehner

    Interesting, but not really what you can/should expect from the average user.


    Indeed, but keep in mind ours is quite a rare edge case that not many have encountered… so far us 2 are the only I know of when searching the web…

    I have other friends with a 4C that have no hassles. and it took a lot of log digging and troubleshooting to get to the route… as our issue isn’t the standard “being blocked by a virus scanner” issue.

    although this is the only device that I have this particular issue with… although digging into the working of the Tobii 4C I do notice that they use rather creative ways to get the eyetracker to communicate with windows. quite interesting stuff, but as with all niche tech, windows will throw a curve ball sometimes,

    here is my batch file… be sure to close ISE first as it wont recognize the eyetracker if you don’t close and open it (the batch file opens ISE after rebooting the service)

    be sure to right click and “run as administrator” when using the batch file

    net stop “Tobii Service”
    net start “Tobii Service”
    cd “C:\Program Files (x86)\Tobii\Tobii InfiniteScreen”
    Start Tobii.InfiniteScreenExtension.exe

    Grant [Tobii]

    Hi @coldza @sylow, thank you for the detailed error report. I was curious if you both had a SoundBlaster card and whether or not disabling the sound card had any effect on the Tobii 4C service starting up?

    In any event, I am glad to managed to find a workaround whilst investigating the root cause. It might also be worth disabling any potentially aggressive Antivirus software running to determine it’s impact.


    Hi Grant,

    No problem,

    I don’t have a Soundblaster Card, using the onboard on my MSI 990FXA-GD65 (Realtek card)

    I have tried all the troubleshooting steps regarding antivirus etc (using windows 10 built in Defender), I even found that some of the anti microsoft privacy measures I put in place was causing windows hello to not funtion properly (it was disabling usage of the camera in the lock screen)

    I have a support ticket open with Tom Jiang Feedback ID: (15256) where we have been checking things off the list regarding interfering candidates, in that support ticket I have included my system information in a .nfo file and the Tobii logs at the time of the error occurring.

    If necessary I can forward that info (Just don’t want to post links to the files here as they contain personal info regarding my setup)

    Kind Regards,


    on another note, I do have remnants of a CSR harmony Bluetooth adapter that isnt in any startup procedure but still finds its way into my windows errorlogs on startup,

    Michael do you have any bluetooth adapters on your computer?

    D Jones

    Hi, I have what sounds like a similar issue – The ET4c works intermittently. I’ve been working with Darren from technical support and tried a number of things to no avail. I have had the device working, but it coincided with seemingly unrelated action; moving to a USB2.0 port from the USB3.0. Once I had the device working, I did not restart my rig for a few days and enjoyed hours of immersive game play. Until I had to restart. Since then, no joy regardless.

    I have looked into the Tobii Service a little closer and there is a problem there, but I cannot fathom what is causing the issue. Using the Service console it reports the service is Automatic, but not running. Hit start, progress bar completes and in the Properties, it reports the service is stopped. Switched to Command Prompt (Admin) and starting the service produces the following

    (c) 2016 Microsoft Corporation. All rights reserved.
    C:\WINDOWS\system32>net stop "tobii service"
    System error 109 has occurred.
    The pipe has been ended.
    C:\WINDOWS\system32>net start "tobii service"
    The Tobii Service service is starting.
    The Tobii Service service was started successfully.
    C:\WINDOWS\system32>net stop "tobii service"
    The Tobii Service service is stopping....
    The Tobii Service service was stopped successfully.
    C:\WINDOWS\system32>net start "tobii service"
    The Tobii Service service is starting.
    The Tobii Service service could not be started.
    A system error has occurred.
    System error 1067 has occurred.
    The process terminated unexpectedly.

    No idea what is causing the problem. I am running the latest versions of Core and ISE (though the latter is not running until the Core functions correctly). I do not have any indication there is any functionality in the device (no infra red lights). I am running on an X99 ASUS Sabertooth mobo. I am also running out of patience with this – it would be a shame to have to return it.

    Michael Lehner

    On the AntiVirus software: i use windows defender. (Bad news for most AV-Software producers: in several tests of renowned computer magazines i read recently, they didn’t fare better than the defender. )

    On bluetooth: i wouldn’t be aware of any bluetooth component on my machine.

    On the last comment: it’s true, as the free USB-port after removing the EyeX was a USB3 port, the 4c now is connected via a USB3 port. I might try switching up things (perhaps even plugging the device to the USB-hub next to my screen), and keep an eye on this. But as the problem is sporadic (i haven’t experienced it now for two days), it’s hard to confirm it as a cure, i can only switch and give feedback if the problem happens again.

    D Jones

    Thanks, I upgraded to the 4c from the EyeX. I had to completely remove any residual footprint for both software parts and cleanly install them again. There was some issue removing the service, no log but it just took a long time for the operation to complete.

    I do have anti virus, but I’ve already disabled it when this issue first started. I did have a USB2.0 hub when I used the EyeX, but I have removed that as I have a plethora of USB connections on the mobo, with a couple of USB2.0 on the chassis.

    Coincidentally, I booted up this morning leaving the device unplugged. The Tobii Eye Tracking software automatically loads on startup and the System Tray showed the spinning waiting wheel and finished saying it could not detect any Eye Tracker connected. I thought I’ll plug the device into (another USB2.0 port) and see what happens. The device was recognised and is now working. I won’t restart for while if I can help it.

    I’ve sent my %temp% files to Tobii support (Darren has been brilliant). Hopefully that will shed some light on the issue.

    Michael Lehner

    As written above, i tried connecting the device another way, it’s currently not on the cable, but plugged to the powered USB-hub on my desk. Funny enough, when the device today at the first system start again displayed the hickup, i now also got an info from the X-56 Profiler (my X-56 joystick and throttle are connected via that hub) that they would be disconnected.

    This is very curious, it’s almost as if the USB connection itself was broken for a moment. Mind you, this is no “expert analyse”, just the impression the messages and system sounds gave me for a moment, when i had several times the sounds of an usb device being disconnected or connected.


    Hi Michael,

    I have the same issue with the “disconnected sound” that happens like 7 times in quick succession when booting windows,

    I have an app called USBLogView.exe to see if it is indeed USB devices connecting and disconnecting, however nothing shows as connecting during the time of the sounds,

    the sound is a generic Windows sound for notifications though…

    So far looking online I have not found a solid reason for that occurrence during bootup

    Michael Lehner

    It’s fascinating… just like the other problems i reported, the last patch did not fix things, but just made it “more weird” and worse.

    The above mentioned method of stoping the tobii software does not work any more. It seems like now, when things fail at reboot, the very only way to fix things is to really reboot the computer. Bonus points: when this problem happens, my X-56 joystick also constantly now gets disconnected and reconnected. Whatever your software is doing with the USB, please make it stop doing that!

    Michael Lehner

    As i disabled the above mentioned delay-script and the method of killing processes and starting things anew after reboot doesn’t work any more the way i did it before the patch, i currently try something else: the device now is usually unpluged, and only gets pluged in when required. I will give feedback if pluging in later can also lead to the above mentioned problems, but i expect to be able to avoid them.


    As with Michael my device has completely stopped working with my PC,

    no more tricks are working,

    It just cycles and doesnt detect,

    it does detect the device but doesnt initialize,

    cycles between http://i.imgur.com/xqqlQlF.png and http://i.imgur.com/BfHULGg.png

Viewing 15 posts - 1 through 15 (of 47 total)
  • You must be logged in to reply to this topic.